Bug 111738 - Install fails with large amts of memory on laptop
Summary: Install fails with large amts of memory on laptop
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-09 15:54 UTC by Pat Julien
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 19:49:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pat Julien 2003-12-09 15:54:46 UTC
Description of problem:When loading Fedora-Core 1 on an IBM Thinkpad
A31 with 1G memory, 512M and then 256M memory we found when the Fedora
reached the point where it was loading image to hard drive (20G)
received message that there is not enough space on hard drive on every
iteration until we reached the point where there was only 256M of
memory.  We tried various configurations, i.e. different hard drives,
different memory sticks, etc.  The only iteration that finally worked
to allow us to load Fedora-Core on the Thinkpad was when we reached a
configuration of 256M of memory.  This allowed us to load the entire
Fedora-Core package.  Once it was loaded we could then bump memory to
1G and all appears to work without problems.
We could load the minimal required to operate with greater than 256M
memory but this was not consistent.


Version-Release number of selected component (if applicable):1


How reproducible:Happens every time


Steps to Reproduce:
1.Load Fedora-Core on laptop with large amounts of memory & hard drive
2.accept all defaults 
3.
  
Actual results: After formating partitions, install fails when loading
image on drive


Expected results:


Additional info:

Comment 1 Jeremy Katz 2003-12-18 20:23:51 UTC
Does booting with 'linux allowcddma' help?

Comment 2 Pat Julien 2003-12-19 12:01:44 UTC
Do not know.  We never tried using this command as we didn't know
about it.  What does it do?  Assume something with dma.  We worked for
2 days trying to get this to load while another A31 seemed to load
easily without problems - we believe it's purely a timing issue.

Comment 3 Jeremy Katz 2003-12-19 20:05:07 UTC
The kernel in Fedora Core 1 is different and has manifested some CD
DMA oddities -- allowcddma changes anaconda's behavior in this respect
somewhat and will help show if that's the problem.

Comment 4 Pat Julien 2003-12-22 11:52:10 UTC
If you provide me with instructions on how to load with the allowcddma
I can try it tomorrow or the next day and let you know if this solved
the problem.  I have a router person coming in today.  Is this command
included in the normal fedora core 1 download or something I have to
download separate?

Comment 5 Jeremy Katz 2003-12-22 16:37:41 UTC
When you get the initial "boot:" prompt, just type "linux allowcddma"
and see what happens, nothing more complicated than that :)

Comment 6 Pat Julien 2003-12-22 19:34:11 UTC
Success!!!  I was able to load everything on the same A31 with 1G
memory and 20G harddrive with using the linux allowcddma command.  

Thanks
Pat Julien

Comment 7 David Lawrence 2004-09-29 19:49:49 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.