Bug 11174 - Adaptec APA1480 Cardbus adapter nolonger loads under 6.2
Adaptec APA1480 Cardbus adapter nolonger loads under 6.2
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Depends On:
  Show dependency treegraph
Reported: 2000-05-02 07:52 EDT by Mark Droog
Modified: 2007-04-18 12:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-05 16:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Droog 2000-05-02 07:52:37 EDT
I have a FOSA 8800C 500Mhz Celeron Laptop.
I have A 3Com 3c574 PCMCIA Network Card and a Adaptec APA1480 Cardbus SCSI
Both cards worked fine under RedHat 6.1, but now under 6.2, I can't get the
SCSI card to load.
Keep Getting AIC7XXX IO ports already in use no matter what I try.
Comment 1 Need Real Name 2000-08-16 14:00:08 EDT
This is also occuring on my Micron Transport Trek 2 AGP laptop.

Comment 2 Bryce Nordgren 2000-08-22 12:25:01 EDT
Same problem on Dell Latitude CPxH laptop.

FIxed it by "demoting" the aic7xxx driver to version 5.1.23.  After applying the
current security 
patches, I was using kernel 2.2.16 which comes with driver version 5.1.30. 
Starting with the 5.1.30 patch, I applied successively older patches (in
reverse) until the machine recognized the card.  version 5.1.23 is the first one
(or rather, the LAST one) which worked.  Examining the changelog indicates that
version 5.1.24 contains a change regarding PCI io port space and how it is
reserved (which is exactly what is causing the card to fail).

Seems happy as a clam now.

Comment 3 Doug Ledford 2000-08-22 12:36:30 EDT
I need the contents of /proc/ioports on some machine that has this problem
before I can go further with a diagnosis.
Comment 4 Bryce Nordgren 2000-08-22 14:05:54 EDT
I sent this in email a week or so ago prior to discovering Bugzilla:


I'm having a problem and I hear that you're the person to talk to.  I have
a brand new Dell Latitude CPx-H laptop which I have just installed RH6.2
on.  I have performed the relevant recommended security updates as per the
website, but other than that, it's a brand-spanking-new installation.  I'm
experiencing a problem with the Adaptec SlimSCSI 1480 PCMCIA controller.

Essentially, when I insert the card it's detected and the aic7xxx driver
is started (as a module) to configure it.  The aic7xxx driver complains
that the I/O ports are already in use and aborts the configuration.  This 
results in /proc/scsi/scsi saying "Attached devices: none".  Unfortunately,  
I do not see the I/O port conflict.  The SCSI adapter asks for 0xa00-0xaff
and should be able to get it.  But the aic7xxx driver (after a call to 
"check_region()") thinks it's already allocated to something else.

This problem also occurs if the card is plugged into the computer at boot

I'm running kernel 2.2.16, with aic7xxx driver 5.1.30.  Straight from the

I would greatly appreciate it if you could help me out.  I've done just
about all I can think of to do without debugging this code with which I am
unfamiliar. :) 


Here's the relevant portion of /var/log/messages:

Aug 10 13:59:29 maggie cardmgr[508]: initializing socket 1
Aug 10 13:59:29 maggie cardmgr[508]: socket 1: Adaptec APA-1480 SCSI Host
Aug 10 13:59:30 maggie cardmgr[508]: executing: 'insmod
Aug 10 13:59:30 maggie cardmgr[508]: executing: 'insmod
Aug 10 13:59:30 maggie kernel: cs: cb_config(bus 35) 
Aug 10 13:59:30 maggie kernel:   fn 0 bar 1: io 0xa00-0xaff 
Aug 10 13:59:30 maggie kernel:   fn 0 bar 2: mem 0x60030000-0x60030fff 
Aug 10 13:59:30 maggie kernel:   fn 0 rom: mem 0x60020000-0x6002ffff 
Aug 10 13:59:30 maggie kernel: apa1480_attach(bus 35, function 0) 
Aug 10 13:59:30 maggie kernel: aic7xxx: <Adaptec PCMCIA SCSI controller>
at PCI 35/0/0 
Aug 10 13:59:30 magAug 10 13:59:30 maggie kernel: apa1480_cs: no SCSI devices
Aug 10 13:59:30 maggie kernel: scsi : 0 hosts. 
Aug 10 13:59:30 maggie cardmgr[508]: get dev info on socket 1 failed: No
such device

Here's the reserved I/O ports (from /proc/ioports): 
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0860-0867 : ide0
0868-086f : ide1
d800-d8ff : ESS Maestro 2E
dc00-dc7f : eth0

Comment 5 Doug Ledford 2000-08-22 14:11:03 EDT
I've heard reports that this is fixed already in the later pcmcia-cs package we
are using in our next release.  Can someone try the kernel from rawhide or from
the public beta and let me know if the problem still exists?
Comment 6 Bryce Nordgren 2000-08-22 14:50:47 EDT
Point me to a URL.  I'm pretty ignorant and don't know what a "rawhide" kernel
is.  I went to the beta release site, but I'm not interested in doing a complete
re-install with the next version of redhat.  But if it's just a kernel recompile
I'd be up for it. :)
Comment 7 Alan Cox 2003-06-05 16:04:55 EDT
Believed fixed, and 6.2 is out of support now

Note You need to log in before you can comment on or make changes to this bug.