Bug 1117447 - [GSS](6.3.1)HHH-9280 Join table name for @ElementCollection of entity class name instead of specified entity name
Summary: [GSS](6.3.1)HHH-9280 Join table name for @ElementCollection of entity class n...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: EAP 6.3.1
Assignee: Gail Badner
QA Contact: Martin Simka
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On: 1114699
Blocks: eap631-blockers, eap631-payload, eap63-cp01-blockers 1121630
TreeView+ depends on / blocked
 
Reported: 2014-07-08 17:41 UTC by Stephen Fikes
Modified: 2018-12-09 18:07 UTC (History)
7 users (show)

(edit)
This release of JBoss EAP 6 carries a bug in the Hibernate component that causes the table name computed for an @ElementCollection to use the entity class name instead of the specified entity name.

This issue is expected to be resolved in a future release of the product.
Clone Of: 1114699
: 1134738 (view as bug list)
(edit)
Last Closed: 2014-10-13 18:38:11 UTC


Attachments (Terms of Use)

Comment 1 Gail Badner 2014-07-09 21:55:16 UTC
I don't think HHH-5417 is accurate any more. I've created a new Jira issue to reflect the current behavior:

https://hibernate.atlassian.net/browse/HHH-9280

Comment 2 Gail Badner 2014-07-10 23:00:51 UTC
I've pushed the fix to 4.2 so it's ready for 6.3.1.

Comment 7 Martin Simka 2014-09-01 16:20:31 UTC
for now verified on EAP 6.3.1.CP.CR1, it's going to be reverted in CR2 because it indroduces new regression. For CP02 it is tracked under BZ1134738


Note You need to log in before you can comment on or make changes to this bug.