Bug 1117459 - [abrt] dnf: base.py:589:do_transaction:NameError: global name 'i18n' is not defined
Summary: [abrt] dnf: base.py:589:do_transaction:NameError: global name 'i18n' is not d...
Keywords:
Status: CLOSED DUPLICATE of bug 1112704
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:74071c130945374f61a221b8583...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 18:16 UTC by jonandmykaela
Modified: 2014-07-09 06:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 06:42:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.43 KB, text/plain)
2014-07-08 18:16 UTC, jonandmykaela
no flags Details
File: environ (3.71 KB, text/plain)
2014-07-08 18:16 UTC, jonandmykaela
no flags Details

Description jonandmykaela 2014-07-08 18:16:29 UTC
Description of problem:
Trying to undo a DNF install of wine

Version-Release number of selected component:
dnf-0.5.2-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf history undo 75
executable:     /usr/bin/dnf
kernel:         3.14.9-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
base.py:589:do_transaction:NameError: global name 'i18n' is not defined

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 206, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 82, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 169, in resolving
    return_code, resultmsgs = base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 231, in do_transaction
    return_code, resultmsgs = super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 589, in do_transaction
    print(i18n.to_utf8(msg))
NameError: global name 'i18n' is not defined

Local variables in innermost frame:
rpmlib_only: False
msgs: [u'wine-tahoma-fonts = 1.7.20-1.fc20 is needed by (installed) wine-tahoma-fonts-system-1.7.20-1.fc20.noarch']
self: <dnf.cli.cli.BaseCli object at 0x162ded0>
msg: u'wine-tahoma-fonts = 1.7.20-1.fc20 is needed by (installed) wine-tahoma-fonts-system-1.7.20-1.fc20.noarch'
rcd_st: 1404843190.260068
dscb: <dnf.cli.output.DepSolveProgressCallBack object at 0x16b5210>
display: <dnf.cli.output.CliTransactionDisplay object at 0x224a790>

Comment 1 jonandmykaela 2014-07-08 18:16:32 UTC
Created attachment 916521 [details]
File: backtrace

Comment 2 jonandmykaela 2014-07-08 18:16:33 UTC
Created attachment 916522 [details]
File: environ

Comment 3 Ales Kozumplik 2014-07-09 06:42:29 UTC

*** This bug has been marked as a duplicate of bug 1112704 ***


Note You need to log in before you can comment on or make changes to this bug.