Bug 1117487 - Highlighted menu doesn't change between katello pages
Summary: Highlighted menu doesn't change between katello pages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 19:22 UTC by Walden Raines
Modified: 2019-09-26 13:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:23:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6531 0 None None None 2016-04-22 16:55:18 UTC

Description Walden Raines 2014-07-08 19:22:36 UTC
After https://github.com/theforeman/foreman/pull/1572 is merged the active (highlighted) parent menu item doesn't update between bastion pages.

Bastion pages need to call foreman's mark_active_menu() on state change after the changes to a single page application in order for the highlighted menu to update.

h3. Steps to Reproduce

 1. After https://github.com/theforeman/foreman/pull/1572 is merged or on that foreman branch go to a Bastion page
 2. Repeat step 1 with another Bastion page not under the same parent menu
 3. Note that the highlighted menu did not change.

Comment 1 Walden Raines 2014-07-08 19:22:37 UTC
Created from redmine issue http://projects.theforeman.org/issues/6531

Comment 2 Walden Raines 2014-07-08 19:22:39 UTC
Upstream bug assigned to walden@redhat.com

Comment 3 Walden Raines 2014-07-08 19:33:17 UTC
PR: https://github.com/Katello/katello/pull/4406

Comment 5 Bryan Kearney 2014-07-15 16:04:17 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6531 has been closed
-------------
Walden Raines
https://github.com/Katello/katello/pull/4406
-------------
Walden Raines
Applied in changeset commit:katello|218ecae9626bbdd8e09580cc7e33b2ab8e6e3218.

Comment 7 sthirugn@redhat.com 2014-09-03 15:11:50 UTC
Verified.

Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140829.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 8 Bryan Kearney 2014-09-11 12:23:22 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.