Bug 1117553 - bitlbee crashes often
Summary: bitlbee crashes often
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bitlbee
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 23:46 UTC by Lokesh Mandvekar
Modified: 2018-04-11 07:15 UTC (History)
4 users (show)

Fixed In Version: bitlbee-3.2.2-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 21:56:02 UTC


Attachments (Terms of Use)

Description Lokesh Mandvekar 2014-07-08 23:46:39 UTC
Description of problem:

I run bitlbee and irssi on my rawhide instance, and I keep getting kicked out of my bitlbee channel randomly.

Version-Release number of selected component (if applicable):
bitlbee-3.2.2-1.fc21.x86_64


How reproducible:
often

Comment 1 Robert Scheck 2014-07-09 00:01:17 UTC
Do you have any backtrace or debugging information?

Comment 2 Lokesh Mandvekar 2014-07-09 01:34:59 UTC
There are many of this sort:


Jul 08 19:57:44 nagato.amegakure.ch bitlbee[16334]: ** (process:16334): CRITICAL **: purple_core_init: assertion 'purple_get_core() == NULL' failed
Jul 08 19:57:44 nagato.amegakure.ch bitlbee[16334]: libpurple initialization failed.
Jul 08 19:58:34 nagato.amegakure.ch bitlbee[16338]: ** (process:16338): CRITICAL **: purple_core_init: assertion 'purple_get_core() == NULL' failed
Jul 08 19:58:34 nagato.amegakure.ch bitlbee[16338]: libpurple initialization failed.
Jul 08 20:01:53 nagato.amegakure.ch bitlbee[16345]: ** (process:16345): CRITICAL **: purple_core_init: assertion 'purple_get_core() == NULL' failed
Jul 08 20:01:53 nagato.amegakure.ch bitlbee[16345]: libpurple initialization failed.


Does this help?

Comment 3 Robert Scheck 2014-07-09 07:30:19 UTC
Do you use any libpurple based functionality? Note that oscar, jabber, yahoo,
msn and twitter protocols are still from BitlBee itself not via libpurple.

Comment 4 Robert Scheck 2014-07-09 11:11:45 UTC
Okay, this is caused due to non-forkdaemon and libpurple. I will build the
package again without libpurple because we can not (yet) switch to bitlbee
forkdaemon mode.

Comment 5 Fedora Update System 2014-07-14 20:21:35 UTC
bitlbee-3.2.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-8126/bitlbee-3.2.2-1.fc19

Comment 6 Fedora Update System 2014-07-14 20:26:05 UTC
bitlbee-3.2.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-8129/bitlbee-3.2.2-2.fc20

Comment 7 Fedora Update System 2014-07-17 04:27:09 UTC
Package bitlbee-3.2.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bitlbee-3.2.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8126/bitlbee-3.2.2-2.fc19
then log in and leave karma (feedback).

Comment 8 Lokesh Mandvekar 2014-07-23 23:23:04 UTC
Robert, thanks for the update, things seem to be working well for me :)

Comment 9 Fedora Update System 2014-07-30 21:56:02 UTC
bitlbee-3.2.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-07-30 21:58:04 UTC
bitlbee-3.2.2-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.