Bug 111756 - 2.6.0 modules debug information too big for mkinitrd
Summary: 2.6.0 modules debug information too big for mkinitrd
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-09 17:42 UTC by William Cohen
Modified: 2007-04-18 17:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-15 21:13:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Cohen 2003-12-09 17:42:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Attempted to build custom kernel using code from
kernel-source-2.6.0-0.test11.1.100. The mkinitrd appears to have
problems because the module are too large due to the debug information.

Results from du of /lib/modules

311992  2.6.0-0.test11.1.100custom
30752   2.4.22-1.2115.nptl
50364   2.6.0-0.test11.1.99
51740   2.6.0-0.test11.1.99smp


Version-Release number of selected component (if applicable):
kernel-source-2.6.0-0.test11.1.100

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-source-2.6.0-0.test11.1.100
2. cp kernel-2.6.0-test11-i686-smp.config .config; make
3. as root
   make modules_install
   make install
    

Actual Results:  make install does not complete the mkinitrd because
the modules are too large.

Expected Results:  the newly built kernel is installed and the "make
install" completes without error.

Additional info:

The following allowed the mkinitrd to work:

cd /lib/modules/2.6.0-0.test11.1.100custom/
find -path "*.ko" -exec strip -d {} \;

Comment 1 Arjan van de Ven 2003-12-15 21:13:40 UTC
fixed in latter mkinitrd.


Note You need to log in before you can comment on or make changes to this bug.