Bug 1117830 - Postgres Plugin - Nullable column is not detected correctly in configuration column view
Summary: Postgres Plugin - Nullable column is not detected correctly in configuration ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 13:16 UTC by Michael Burman
Modified: 2014-12-11 14:04 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:04:52 UTC


Attachments (Terms of Use)

Description Michael Burman 2014-07-09 13:16:07 UTC
Description of problem: Postgres plugin is showing not none of the columns are nullable, when in fact some of them are. 

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Open a table with both nullable and non-nullable columns
2. Go to configuration and view current status
3.

Actual results: None of the columns are nullable

Expected results: Should show some columns with nullable box checked and some without.


Additional info: This might because of a bug in the postgresql-jdbc-driver, it's not necessarily filling "IS_NULLABLE" info correctly.

Comment 2 Michael Burman 2014-08-13 09:00:12 UTC
Fixed in master:

commit 7eec179000bb53950f4d6c4eebeef0b33821e79b
Author: Michael Burman <miburman@redhat.com>
Date:   Tue Aug 12 23:09:37 2014 +0300

    [BZ 1117830] Parse nullable from NULLABLE instead of IS_NULLABLE

Comment 3 Thomas Segismont 2014-08-25 08:58:23 UTC
Cherry-picked over to release/jon3.3.x

commit 7f014598b83b351063540731ed93a83bb5f86711
Author: Michael Burman <miburman@redhat.com>
Date:   Tue Aug 12 23:09:37 2014 +0300

    [BZ 1117830] Parse nullable from NULLABLE instead of IS_NULLABLE
    
    (cherry picked from commit 7eec179000bb53950f4d6c4eebeef0b33821e79b)
    Signed-off-by: Thomas Segismont <tsegismo@redhat.com>

Comment 4 Simeon Pinder 2014-09-03 20:31:53 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194


Note You need to log in before you can comment on or make changes to this bug.