Bug 111784 - e-mail user agent setup isn't quite right for imaps
e-mail user agent setup isn't quite right for imaps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhel-rg (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrius Benokraitis
John Ha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 22:05 EST by Pierre F. Maldague
Modified: 2015-07-14 00:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-12 16:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre F. Maldague 2003-12-09 22:05:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
In section 12.5.1.2 (securing email client communications), I see
2 mistakes.

First, to create a self-signed certificate, you instruct the
reader to cd to /usr/share/ssl/certs/ and run make imapd.pem.
This is good, except that rpm installs an imapd.pem file by
default, which must be removed first (otherwise 'make' reports
that all is up to date.)

Second, once the certificate has been created you instruct the
reader to run /sbin/services with the imaps option. But this does
not work, because there is no imaps script in /etc/init.d. The
correct option is to edit the imaps file in /etc/xinetd.d/imaps
file so that the value of the 'disable' field is set to no instead
of yes.

Even though I am reporting a bug, finding the workaround wasn't bad
and my mail server has been up and running in record time. Keep up
the good work and keep fixing all these little details!!

Version-Release number of selected component (if applicable):
rhel-rg(EN)-3-HTML-RHI (2003-07-25T17:13)

How reproducible:
Always

Steps to Reproduce:
1.type 'make imapd.pem' in /usr/share/ssl/certs/ and watch it reply
that imapd.pem is up to date.
2. type '/sbin/services imaps' and watch it respond that imaps is an
unknown service.
3.
    

Actual Results:  1. 'imapd.pem' is up to date
2. imaps: unknown service

Expected Results:  1. "How are you today?" (Just kidding -- I expected
a few questions like name, company, domain name, address etc.)
2. command prompt with no errors

Additional info:

Note You need to log in before you can comment on or make changes to this bug.