Bug 111785 - Rhythmbox fails to read the artist tag of ogg files under Turkish locale
Rhythmbox fails to read the artist tag of ogg files under Turkish locale
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 22:09 EST by Alaeddin A. Aydiner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 00:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alaeddin A. Aydiner 2003-12-09 22:09:53 EST
Description of problem:
Under the Turkish locale, uppercase 'i' is not I. Hence, when
rhythmbox reads song information from an ogg file, the artist
tag is not probably detected. In other words, some code either
in gstreamer or rhythmbox assumes lowercase of I is always i
when checking the tag...

Version-Release number of selected component (if applicable):
rhythmbox-0.5.4-1

How reproducible:
Always

Steps to Reproduce:
1. export LC_ALL=tr_TR.UTF-8; or choose the Turkish locale under gdm
2. Run rhythmbox and add ogg songs with ARTIST tags
  
Actual results:
The artist tags are not be detected.

Expected results:
The tags should be detected.

Additional info:
This may not be a rhythmbox problem if it relies on some other library
to read the tags. If it is the case, the bug may need to be "forwarded"...
Comment 1 Alaeddin A. Aydiner 2003-12-10 00:46:59 EST
The very same problem affects titles too because of the uppercase 'I'
in the TITLE tag. I did not notice it first because filenames were
being used by rhythmbox instead.
Comment 2 Alaeddin A. Aydiner 2003-12-16 22:31:31 EST
I think gtk+ (or perhaps a related) library must have some functions
to do locale dependent tolower, toupper etc. instead of the regular
ones. Those should fix the problem here...
Comment 3 Colin Walters 2004-04-02 10:17:14 EST
We already use g_utf8_casefold.  If that doesn't behave correctly in a
Turkish locale, it's a glib bug.

By the way, could you verify whether or not this bug is still present
in the latest development Rhythmbox 0.7.x? (0.7.2 should be out soon)
Comment 4 Alaeddin A. Aydiner 2004-09-22 00:34:37 EDT
Hi Colin,

Please close this ticket. The problem is fixed with the newer version
of Rhythmbox, at least as far as ogg files are concerned. mp3 tags do
have a similar problem, but I guess that is due to the mp3 tag library
(?) that rhythmbox uses.

Anyway, the general inflexibility, bad design etc. of mp3 tags, _any_
version, is convincing enough to convert mp3s to oggs!

Thanks.


Comment 5 Colin Walters 2004-09-22 00:57:38 EDT
Rhythmbox uses GStreamer to read metadata (tags) now in 0.8.

mp3 tags are a whole other issue because for v1 tags there is no
character set information, and for v2 even though there is a character
set flag, it's often set incorrectly.

ogg got it right by just mandating UTF-8.

Note You need to log in before you can comment on or make changes to this bug.