Bug 1117903 - Rebase openstack-sahara to 2014.1.1
Summary: Rebase openstack-sahara to 2014.1.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Michael McCune
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 15:23 UTC by Lon Hohberger
Modified: 2016-04-26 20:07 UTC (History)
9 users (show)

Fixed In Version: openstack-sahara-2014.1.1-2.el7ost python-django-sahara-2014.1.1-1.el7ost
Doc Type: Rebase: Bug Fixes Only
Doc Text:
This rebase package includes a number of notable enhancements and fixes under version 2014.1.1: * Fixed validation of node group templates using Nova networking with auto assignment of floating IPs. * Fixed occasional failure to launch EDP jobs on transient clusters. * Fixed issue with transient cluster creation failing due to incorrect tenant id. * Updated architecture diagram and IRC channel name in documentation.
Clone Of:
Environment:
Last Closed: 2014-07-24 17:23:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0937 0 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix and Enhancement Advisory 2014-07-24 21:21:56 UTC

Description Lon Hohberger 2014-07-09 15:23:41 UTC
Rebase python-django-sahara to 2014.1.1.  If appropriate, link any critical issues addressed in this rebase.

Comment 7 Luigi Toscano 2014-07-17 13:37:23 UTC
It seems there is a regression when the sahara-db-update command is run (at the beginning of installation):

Command executed: 
sahara-db-manage --config-file /etc/sahara/sahara.conf upgrade head


12:52:11 stderr: Traceback (most recent call last):
12:52:11   File "/bin/sahara-db-manage", line 10, in <module>
12:52:11     sys.exit(main())
12:52:11   File "/usr/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 111, in main
12:52:11     CONF.command.func(config, CONF.command.name)
12:52:11   File "/usr/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 50, in do_upgrade_downgrade
12:52:11     do_alembic_command(config, cmd, revision, sql=CONF.command.sql)
12:52:11   File "/usr/lib/python2.7/site-packages/sahara/db/migration/cli.py", line 31, in do_alembic_command
12:52:11     getattr(alembic_cmd, cmd)(config, *args, **kwargs)
12:52:11   File "/usr/lib/python2.7/site-packages/alembic/command.py", line 124, in upgrade
12:52:11     script.run_env()
12:52:11   File "/usr/lib/python2.7/site-packages/alembic/script.py", line 191, in run_env
12:52:11     util.load_python_file(self.dir, 'env.py')
12:52:11   File "/usr/lib/python2.7/site-packages/alembic/util.py", line 186, in load_python_file
12:52:11     module = imp.load_source(module_id, path, open(path, 'rb'))
12:52:11 IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/sahara/db/migration/alembic_migrations/env.py'


openstack-sahara-2014.1.1-1.el7ost.noarch

Moving back to ASSIGNED.

Comment 10 Luigi Toscano 2014-07-24 00:07:46 UTC
The rebased packages:
openstack-sahara-2014.1.1-2
python-django-sahara-2014.1.1-1
can be installed and work as the previous version. Moving to VERIFIED.

Comment 12 errata-xmlrpc 2014-07-24 17:23:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0937.html


Note You need to log in before you can comment on or make changes to this bug.