Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1117907 - Rubygem-Staypuft: Resuming paused deployment doesn't reset the status upon success.
Summary: Rubygem-Staypuft: Resuming paused deployment doesn't reset the status upon s...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-foreman-tasks
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: Installer
Assignee: Petr Chalupa
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 15:34 UTC by Alexander Chuzhoy
Modified: 2015-05-05 01:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 14:49:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2014-07-09 15:34:11 UTC
Environment: rhel-osp-installer-0.1.0-2.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer
2. Create a deployment with 3 hosts (Nova controller +2 compute nodes)
3. The deployment gets stuck on 60% installing the controller. This happens due to puppet errors.
4. Fix the pupper errors to a state where puppet run finishes with no errors.
5. Resume the deployment.


Result:
 The progress bar remains red and the status of Result remains "error". At the same time the deployment continues and there are no errors in the errors tab.

Expected:
 The progress bar and the result status should be cleared.

Comment 3 Petr Chalupa 2014-08-07 15:05:35 UTC
fixed in https://github.com/theforeman/foreman-tasks/pull/80

Comment 4 Petr Chalupa 2014-10-08 09:03:42 UTC
PR merged, will be in version > 0.6.10


Note You need to log in before you can comment on or make changes to this bug.