Bug 1117911 - Logsys file leaks in /dev/shm after sigabrt, sigsegv and when running corosync -v
Summary: Logsys file leaks in /dev/shm after sigabrt, sigsegv and when running corosyn...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 15:38 UTC by Jan Friesse
Modified: 2015-03-05 08:27 UTC (History)
3 users (show)

Fixed In Version: corosync-2.3.3-3.el7
Doc Type: Bug Fix
Doc Text:
Cause: Corosync receives sigabrt or sigsegv signal or user executes corosync -f Consequence: Files in /dev/shm created by corosync are not deleted resulting in lost of space in /dev/shm (-> memory) Fix: Properly register signal handlers and make sure to call cleanup function when processing -v parameter. Result: No files left in /dev/shm.
Clone Of:
Environment:
Last Closed: 2015-03-05 08:27:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix memory leak produced by 'corosync -v' (1.06 KB, patch)
2014-07-09 15:39 UTC, Jan Friesse
no flags Details | Diff
Handle SIGSEGV and SIGABRT signals (1.13 KB, patch)
2014-07-09 15:39 UTC, Jan Friesse
no flags Details | Diff
Fix compiler warning introduced by previous patch (1.79 KB, patch)
2014-07-09 15:39 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0365 normal SHIPPED_LIVE corosync bug fix and enhancement update 2015-03-05 12:51:37 UTC

Description Jan Friesse 2014-07-09 15:38:16 UTC
Description of problem:
When corosync receives sigabrt or sigsegv it doesn't delete libqb blackbox file (/dev/shm one). Same happens when corosync is executed with -v parameter (this shows only version, so it shouldn't cause leak in /dev/shm).

Version-Release number of selected component (if applicable):
7.0

How reproducible:
100%

Steps to Reproduce 1:
1. Start corosync
2. Send sigabrt to corosync

Steps to Reproduce 1:
1. Execute corosync -v

Actual results:
File like qb-corosync-*-blackbox-data|header exists results in leak of /dev/shm space.


Expected results:
No leak

Additional info:

Comment 2 Jan Friesse 2014-07-09 15:39:16 UTC
Created attachment 916863 [details]
fix memory leak produced by 'corosync -v'

fix memory leak produced by 'corosync -v'

Signed-off-by: zouyu <hopkings2005@gmail.com>
Reviewed-by: Jan Friesse <jfriesse@redhat.com>

Comment 3 Jan Friesse 2014-07-09 15:39:22 UTC
Created attachment 916864 [details]
Handle SIGSEGV and SIGABRT signals

Handle SIGSEGV and SIGABRT signals

SIGSEGV and SIGABRT signals are now correctly handled (blackbox is
dumped and logsys is finalized).

Signed-off-by: zouyu <hopkings2005@gmail.com>
Reviewed-by: Jan Friesse <jfriesse@redhat.com>

Comment 4 Jan Friesse 2014-07-09 15:39:28 UTC
Created attachment 916865 [details]
Fix compiler warning introduced by previous patch

Fix compiler warning introduced by previous patch

QB loop signal handler prototype differs from signal(2) prototype.
Solution is to create wrapper functions.

Signed-off-by: Jan Friesse <jfriesse@redhat.com>

Comment 10 errata-xmlrpc 2015-03-05 08:27:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0365.html


Note You need to log in before you can comment on or make changes to this bug.