Bug 1117923 - DHT :- rm -rf is not removing stale link file and because of that unable to create file having same name as stale link file
Summary: DHT :- rm -rf is not removing stale link file and because of that unable to c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: pre-release
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1117283
Blocks: 1138389 1139170 1139992
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:04 UTC by Susant Kumar Palai
Modified: 2015-05-14 17:42 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1117283
: 1138389 1139170 1139992 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-07-09 16:07:58 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#2) for review on master by susant palai (spalai@redhat.com)

Comment 2 Anand Avati 2014-07-15 10:07:23 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#3) for review on master by susant palai (spalai@redhat.com)

Comment 3 Anand Avati 2014-07-16 05:19:13 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#4) for review on master by susant palai (spalai@redhat.com)

Comment 4 Anand Avati 2014-07-17 05:06:18 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#5) for review on master by susant palai (spalai@redhat.com)

Comment 5 Anand Avati 2014-07-17 05:08:10 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#6) for review on master by susant palai (spalai@redhat.com)

Comment 6 Anand Avati 2014-07-17 05:11:17 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#7) for review on master by susant palai (spalai@redhat.com)

Comment 7 Anand Avati 2014-07-17 17:21:08 UTC
REVIEW: http://review.gluster.org/8277 (DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path) posted (#8) for review on master by susant palai (spalai@redhat.com)

Comment 8 Anand Avati 2014-07-17 19:26:55 UTC
COMMIT: http://review.gluster.org/8277 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 52da727e7564963a8a244fc5cb7028315e458529
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Jul 9 09:31:45 2014 -0400

    DHT/Create : Failing to identify a linkto file in lookup_everywhere_cbk path
    
    In case a file is not found in its cached subvol we proceed with
    dht_lookup_everywhere. But as we dont add the linkto xattr to the
    dictionary, we fail to identify any linkto file encountered.The
    implication being we end up thinking the linkto file as a regular file
    and proceed with the fop.
    
    Change-Id: Iab02dc60e84bb1aeab49182f680c0631c33947e2
    BUG: 1117923
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/8277
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 9 Niels de Vos 2015-05-14 17:26:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:35:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:42:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.