Bug 1117925 - Unable to install feature switchyard-sap
Summary: Unable to install feature switchyard-sap
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: tcunning
QA Contact: Václav Chalupa
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:12 UTC by Martin Basovník
Modified: 2016-12-01 00:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Karaf Karaf version 2.3.0.redhat-610379 OSGi Framework org.apache.felix.framework - 4.0.3.redhat-610379 JVM Java Virtual Machine Java HotSpot(TM) 64-Bit Server VM version 24.60-b09 Version 1.7.0_60 Vendor Oracle Corporation
Last Closed: 2015-08-31 15:23:42 UTC
Type: Bug


Attachments (Terms of Use)
Intallation log for feature "switchyard-sap" (3.43 KB, text/x-log)
2014-07-09 16:12 UTC, Martin Basovník
no flags Details

Description Martin Basovník 2014-07-09 16:12:00 UTC
Created attachment 916877 [details]
Intallation log for feature "switchyard-sap"

=== Description of problem:
Unable to install feature "switchyard-sap". 

This bug blocks installation of following quickstart!
switchyard-quickstart-camel-sap-binding

=== Version-Release number of selected component (if applicable):
fsw-6.1.0-DR1

=== How reproducible:
100%

=== Steps to Reproduce:
1. features:addurl mvn:org.switchyard.karaf/switchyard/2.0.0.Alpha1-redhat-1/xml/features
2 features:install -v switchyard-sap

=== Actual results:
see log

Unsatisfied requirement(s):
---------------------------
   package:(&(package=com.sap.conn.jco.ext))
      JBoss Fuse :: Components :: SAP JCO :: Camel Component
   package:(&(package=com.sap.conn.jco))
      JBoss Fuse :: Components :: SAP JCO :: Camel Component
   package:(&(package=com.sap.conn.jco.server))
      JBoss Fuse :: Components :: SAP JCO :: Camel Component

=== Expected results:


=== Additional info:

Comment 1 Jiri Sedlacek 2014-09-05 11:14:37 UTC
Present in DR2 as well, SAP JCO libraries are not part of fuse installation.

This is not a big problem for plain karaf fuse installation, but for fabric profile, there is switchyard-sap feature present, which doesn't allow to apply the fsw-switchyard profile.

Comment 3 tcunning 2015-08-31 15:23:42 UTC
This issue is out of date and has been subsequently fixed, so I'm closing it.


Note You need to log in before you can comment on or make changes to this bug.