Bug 1117973 - Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel) Requires: python-itsdangerous
Summary: Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel) Requires...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-ceilometer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Eoghan Glynn
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 18:11 UTC by wes hayutin
Modified: 2014-07-09 19:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 19:01:10 UTC


Attachments (Terms of Use)
install and config logs (4.36 MB, application/octet-stream)
2014-07-09 18:11 UTC, wes hayutin
no flags Details

Description wes hayutin 2014-07-09 18:11:26 UTC
Created attachment 916917 [details]
install and config logs

Description of problem:

00:36:31.994 ERROR : Error appeared during Puppet run: 172.16.7.17_nova.pp
00:36:31.994 Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-ceilometer-compute' returned 1: Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel)
00:36:31.994 You will find full trace in log /var/tmp/packstack/20140709-084808-xV3IG6/manifests/172.16.7.17_nova.pp.log


[1;31mError: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-ceilometer-compute' returned 1: Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel)
           Requires: python-itsdangerous
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest[0m
[1;31mError: /Stage[main]/Ceilometer::Agent::Compute/Package[ceilometer-agent-compute]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-ceilometer-compute' returned 1: Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel)
           Requires: python-itsdangerous
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest[0m

Comment 1 Alan Pevec 2014-07-09 18:29:16 UTC
Looks like EPEL7 started to depend on RHEL Extras:
https://fedoraproject.org/wiki/EPEL/epel7
"RHEL 7 (channels rhel-7-server-extras-rpms, rhel-7-server-optional-rpms, rhel-7-server-rpms and rhel-ha-for-rhel-7-server-rpms)"


Note You need to log in before you can comment on or make changes to this bug.