Bug 1118010 - packstack should set the l2population option to true in all nodes
Summary: packstack should set the l2population option to true in all nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Linux
high
urgent
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Gaël Chamoulaud
QA Contact: Nir Magnezi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 20:34 UTC by Nir Magnezi
Modified: 2014-09-08 05:44 UTC (History)
10 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.34.dev1219.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 17:25:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0930 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug-fix advisory 2014-07-24 21:22:40 UTC
OpenStack gerrit 106104 None None None Never

Description Nir Magnezi 2014-07-09 20:34:12 UTC
Description of problem:
=======================
packstack should set the l2population option to true in all nodes.
currently it only configure that option in the CONFIG_CONTROLLER_HOST

Version-Release number of selected component (if applicable):
=============================================================
Icehouse.
openstack-packstack-puppet-2014.1.1-0.32.1.dev1209.el7ost.noarch
openstack-packstack-2014.1.1-0.32.1.dev1209.el7ost.noarch

How reproducible:
=================
2/2

Steps to Reproduce:
===================
1. specify l2population in CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS
2. run packstack
3.

Actual results:
===============
as stated above.

Expected results:
=================
l2population =  true --> in all nodes.

Comment 2 Nir Magnezi 2014-07-10 06:42:11 UTC
When I think about it, 
I see no reason to set this flag in CONFIG_CONTROLLER_HOST.

That node should not contain l2 agent anyway (see Bug #1076888 Comment #0).
Please enable that flag only on nodes that populate l2 agents.

Comment 4 Ofer Blaut 2014-07-10 07:16:14 UTC
The original support  support for packstack L2 pop was introduced in https://bugzilla.redhat.com/show_bug.cgi?id=1080947 

l2_population = True is enabled on controller host only,

So if Network node and controller node are on the same host we will have issues


The workaround is to configure l2_population = True in /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini  on all hosts contain L2 agents

Comment 5 Assaf Muller 2014-07-10 08:36:37 UTC
Raising severity to urgent as setting l2pop in Packstack breaks all networking.

Comment 6 Gaël Chamoulaud 2014-07-10 15:36:47 UTC
The most recent stable/icehouse[1] of puppet-neutron fixes this bug.
In the meantime, lbezdick is working on a packstack patch to use the new puppet-neutron coming from [1].

[1] - https://github.com/redhat-openstack/openstack-puppet-modules/pull/81

Comment 8 Gaël Chamoulaud 2014-07-11 13:35:54 UTC
Fixed in version: openstack-packstack-2014.1.1-0.34.dev1219.el7ost
**Needs openstack-puppet-modules-2014.1-19.1.el7ost to work !**

Comment 10 Nir Magnezi 2014-07-20 07:01:08 UTC
Verified NVR: openstack-packstack-2014.1.1-0.35.dev1220.el7ost.noarch

Verification Steps:
===================
I used packstack to deploy a distributed openstack setup. 

Result:
=======
CONFIG_CONTROLLER_HOST: /etc/neutron/plugins/ml2/ml2_conf.ini: 
mechanism_drivers =openvswitch,l2population

CONFIG_COMPUTE_HOSTS: /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:
l2_population = True

CONFIG_NETWORK_HOSTS: /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:
l2_population = True

Comment 12 errata-xmlrpc 2014-07-24 17:25:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0930.html


Note You need to log in before you can comment on or make changes to this bug.