Bug 1118012 - Typos in subscription-manager(8) man page
Summary: Typos in subscription-manager(8) man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.11
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Chris Snyder
QA Contact: John Sefler
URL:
Whiteboard:
: 1174376 (view as bug list)
Depends On:
Blocks: rhsm-rhel511 1118755
TreeView+ depends on / blocked
 
Reported: 2014-07-09 20:40 UTC by Chris Roberts
Modified: 2015-01-06 20:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Here's a sample of some of its typos: s/alll/all/ s/whetehr/whether/ s/notalready/not already/ s/overide/override/ s/registing/registering/
Clone Of:
: 1118755 (view as bug list)
Environment:
Last Closed: 2014-09-16 00:23:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1225 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-09-16 04:15:23 UTC

Description Chris Roberts 2014-07-09 20:40:13 UTC
Here's a sample of some of its typos:
  s/alll/all/
  s/whetehr/whether/
  s/notalready/not already/
  s/overide/override/
  s/registing/registering/

Comment 2 Petr Bokoc 2014-07-10 11:59:21 UTC
This belongs to the subscription-manager component, not the Installation Guide. Reassigning.

Comment 3 John Sefler 2014-07-10 13:45:51 UTC
agreed...

[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.10.14-7.el7.x86_64
[root@jsefler-7 ~]# man -P cat subscription-manager | tail -1
version 2.8                 January 29, 2014     subscription-manager(8)


[root@jsefler-7 ~]# man -P cat subscription-manager > manpage.txt
[root@jsefler-7 ~]# grep alll manpage.txt
       --remove-alll
[root@jsefler-7 ~]# grep whetehr manpage.txt
       --show Shows whetehr auto-attach is enabled on the systems.
[root@jsefler-7 ~]# grep notalready manpage.txt
              Shows  pools  which  provide  products that are notalready
[root@jsefler-7 ~]# grep overide manpage.txt
              Adds  a  named  overide  with  the provided value to repos
              Removes a named overide from the repos specified with  the
[root@jsefler-7 ~]# grep registing manpage.txt
       scription management (registing and applying subscriptions) to be
[root@jsefler-7 ~]# 


Let's see if we can get this fixed sooner
Moving to RHEL5.11 for a fix in subscription-manager-1.11

Comment 4 RHEL Product and Program Management 2014-07-10 13:57:41 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 6 Carter Kozak 2014-07-14 15:38:21 UTC
commit 3a8c703b8f4548688fae60bb2f6e173ad3bd10cb
Author: cnsnyder <csnyder@redhat.com>
Date:   Mon Jul 14 11:24:28 2014 -0400

    1118012: Fixes several typos in man page.

Comment 8 John Sefler 2014-07-15 15:20:58 UTC
Verifying Version...

[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.11.3-9.el5
[root@jsefler-5 ~]# man -P cat subscription-manager | tail -1
version 2.8                    January 29, 2014        subscription-manager(8)
^^^^^^^^^^^                    ^^^^^^^^^^^^^^^^
Has not been bumped?


[root@jsefler-5 ~]# man -P cat subscription-manager > manpage.txt
[root@jsefler-5 ~]# grep alll manpage.txt
[root@jsefler-5 ~]# grep whetehr manpage.txt
[root@jsefler-5 ~]# grep notalready manpage.txt
[root@jsefler-5 ~]# grep overide manpage.txt
[root@jsefler-5 ~]# grep registing manpage.txt
[root@jsefler-5 ~]# 

VERIFIED: known typos have been removed



Additional info....
There were several other grammatical changes committed too.  Here's a complete list of typo/grammatical changes....


[jsefler@jseflerT5400 subscription-manager]$ git diff -U0 6d46d55e96f78b2902fa1a47aaf756e1ee292eab~1 6d46d55e96f78b2902fa1a47aaf756e1ee292eab | egrep -v ^@@
diff --git a/man/subscription-manager.8 b/man/subscription-manager.8
index 599cda2..e48c487 100644
--- a/man/subscription-manager.8
+++ b/man/subscription-manager.8
-.TH subscription-manager 8 "January 29, 2014" "version 2.8" "Subscription Management"  Deon Lackey 
+.TH subscription-manager 8 "January 29, 2014" "version 2.8" "Subscription Management"  Deon Lackey
-Subscription Manager can be used to autoattach subscriptions to a system, as well. The
+Subscription Manager can be used to auto-attach subscriptions to a system, as well. The
-Gives the user account password. This is required.
+Gives the user account password.
-Gives a comma-separated list of product keys to use to redeem or apply specific subscriptions to the system. This is used for preconfigured systems, which may already have products installed and subscriptions attached to that system. Activation keys are issued by an on-premise subscription management service, such as Subscription Asset Manager.
+Gives a comma-separated list of product keys to use to redeem or apply specific subscriptions to the system. This is used for preconfigured systems which may already have products installed. Activation keys are issued by an on-premise subscription management service, such as Subscription Asset Manager.
-Automatically attaches the best-matched, compatible subscriptions to this system.
+Automatically attaches compatible subscriptions to this system.
-Shows whetehr auto-attach is enabled on the systems.
+Shows whether auto-attach is enabled on the systems.
-for products installed on the system. For example, if the service level preference is standard, then a subscription with a standard service level is selected when autoattaching subscriptions to the system.
+for products installed on the system. For example, if the service level preference is standard, then a subscription with a standard service level is selected when auto-attaching subscriptions to the system.
-command imports and applies a subscription certificate for the system which was generated externally, such as in the Customer Portal, and then copied over to the system. Importing can be necessary if a system is pre-configured in the subscription management service or if it is offline or unable to access the subscription management service but it have the proper, relevant subscriptions attached to the system.
+command imports and applies a subscription certificate for the system which was generated externally, such as in the Customer Portal, and then copied over to the system. Importing can be necessary if a system is preconfigured in the subscription management service or if it is offline or unable to access the subscription management service but it has the proper, relevant subscriptions attached to the system.
-command is used for systems that are purchased from third-party vendors that include a subscription. The redemption process essentially autoattaches the pre-selected subscription that the vendor supplied to the system.
+command is used for systems that are purchased from third-party vendors that include a subscription. The redemption process essentially auto-attaches the preselected subscription that the vendor supplied to the system.
-Shows pools which provide products that are notalready covered; only used with
+Shows pools which provide products that are not already covered; only used with
-Gives the user account password. This is required.
+Gives the user account password.
-Gives the user account password. This is required.
+Gives the user account password.
-command list the available subscription-manager plugins.
+command lists the available subscription-manager plugins.
-command displays information about the current Subscription Manager packages and whatever subscription service the system is registered with. For example:
+command displays information about the current Subscription Manager package, the subscription service the system is registered to (if it is currently registered), and the subscription management server that the system is configured to use. For example:
-This has been replaced with attach. A similar registration option, \fB--subscribe\fP, has also be replaced with \fB--autoattach\fP.
+This has been replaced with attach. A similar registration option, \fB--subscribe\fP, has also be replaced with \fB--auto-attach\fP.
-Autoattach also supports an option to set a preferred service level with the selected subscriptions, the
+Auto-attach also supports an option to set a preferred service level with the selected subscriptions, the
-option sets a preference that helps the autoattach process select appropriate subscriptions. For example, if the preferred service level for a production server is premium, and there are three matching subscriptions with different service levels (none, standard, and premium), the autoattach process selects the subscription which offers a premium service level.
+option sets a preference that helps the auto-attach process select appropriate subscriptions. For example, if the preferred service level for a production server is premium, and there are three matching subscriptions with different service levels (none, standard, and premium), the auto-attach process selects the subscription which offers a premium service level.
-command shows you what subscriptions are available specifically to the system (meaning subscriptions which are active, have available quantities, and match the hardware and architecture) or all  subscriptions for the organization. Using the
+command shows you what subscriptions are available specifically to the system (meaning subscriptions which are active, have available quantities, and match the hardware and architecture) or all subscriptions for the organization. Using the
-command, the system can be autoattached to the best-fitting subscriptions using the
+command, the system can be auto-attached to the best-fitting subscriptions using the
-Autoattach also supports an option to set a preferred service level with the selected subscriptions, the
+Auto-attach also supports an option to set a preferred service level with the selected subscriptions, the
-option sets a preference that helps the autoattach process select appropriate subscriptions. For example, if the preferred service level for a production server is premium, and there are three matching subscriptions with different service levels (none, standard, and premium), the autoattach process selects the subscription which offers a premium subscription.
+option sets a preference that helps the auto-attach process select appropriate subscriptions. For example, if the preferred service level for a production server is premium, and there are three matching subscriptions with different service levels (none, standard, and premium), the auto-attach process selects the subscription which offers a premium subscription.
-Sometimes, a system may come pre-configured with products and subscriptions. Rather than attaching a pool and claiming a subscription, this system simply needs to
+Sometimes, a system may come preconfigured with products and subscriptions. Rather than attaching a pool and claiming a subscription, this system simply needs to
-After registration, subscriptions on pre-configured systems can be claimed using the
+After registration, subscriptions on preconfigured systems can be claimed using the
-command, which essentially autoattaches the system to its pre-existing subscriptions.
+command, which essentially auto-attaches the system to its preexisting subscriptions.
-Red Hat has a hosted environment, through the Customer Portal, that provides centralized access to subscription management and content repositories. However, organizations can use other tools -- like Subscription Manager -- for content hosting  and subscription management. With a local content provider, the organization, environments, repositories, and other structural configuration is performed in the content provider. Red Hat Subscription Manager can be used to display this information, using the
+Red Hat has a hosted environment, through the Customer Portal, that provides centralized access to subscription management and content repositories. However, organizations can use other tools -- like Subscription Manager -- for content hosting and subscription management. With a local content provider, the organization, environments, repositories, and other structural configuration is performed in the content provider. Red Hat Subscription Manager can be used to display this information, using the
-tool can be run as a post-install script as part of the kickstart installation process. This allows subscription management (registing and applying subscriptions) to be automated along with installation. For example:
+tool can be run as a post-install script as part of the kickstart installation process. This allows subscription management (registering and applying subscriptions) to be automated along with installation. For example:
[jsefler@jseflerT5400 subscription-manager]$

Comment 10 errata-xmlrpc 2014-09-16 00:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1225.html

Comment 11 John Sefler 2015-01-06 20:27:55 UTC
*** Bug 1174376 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.