Bug 111804 - Missing dependencies for XFree86-devel on GL and GLU sub-packages
Missing dependencies for XFree86-devel on GL and GLU sub-packages
Status: CLOSED DUPLICATE of bug 111794
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-10 07:11 EST by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2003-12-10 07:11:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The XFree86-devel package contains the following symlinks :

/usr/X11R6/lib/libGL.so
/usr/X11R6/lib/libGLU.so

But the current dependencies allow a situation where XFree86-devel is
installed but not XFree86-Mesa-libGLU (verified), and possibly not
XFree86-Mesa-libGL either. In such case, it seems linking works but
gives unresolved symbols in the applications.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1. Install a minimal Fedora Core system (no X)
2. Install XFree86-devel and its dependencies
3. Try to compile an application which needs to be linked against
libGLU, for instance perl-SDL
    

Actual Results: 
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/SDL_perl/SDL
_perl.so: undefined symbol: _Znwj at
/usr/lib/perl5/5.8.1/i386-linux-thread-multi/DynaLoader.pm line 229.

Expected Results:  The library should be linked fine.

Additional info:

When adding XFree86-Mesa-libGLU to the build requirements, the
resulting SDL_perl.so module works fine.
Comment 1 Mike A. Harris 2003-12-10 17:50:27 EST

*** This bug has been marked as a duplicate of 111794 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.