Bug 1118061 - Standalone or host server discovery throws warning every 15 minutes: Management user properties at [<JBOSS_HOME>/{domain,standalone}/configuration/mgmt-users.properties] is not readable.
Summary: Standalone or host server discovery throws warning every 15 minutes: Manageme...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: DR01
: JON 3.3.0
Assignee: Jay Shaughnessy
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 22:51 UTC by Larry O'Leary
Modified: 2014-12-11 14:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:04:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Larry O'Leary 2014-07-09 22:51:57 UTC
Description of problem:
When the agent runs server discovery it logs a warning saying it can't read a file it does not have read permissions for. This should not happen. The agent has no reason to read the files:

    <JBOSS_HOME>/{domain,standalone}/configuration/mgmt-users.properties

Version-Release number of selected component (if applicable):
3.2.0.GA

How reproducible:
Always

Steps to Reproduce:
1. Install JBoss EAP 6 server using the user jbossadmin
2. Install JBoss ON agent using the user jbossonadmin
3. Start JBoss EAP 6 standalone server and JBoss ON agent

Actual results:
Every 15 minutes agent throws the following warning:

    WARN  [ResourceDiscoveryComponent.invoker.daemon-32] (rhq.modules.plugins.jbossas7.StandaloneASDiscovery)- Management user properties at [/opt/jboss/jboss-eap/jboss-eap-6.2/standalone/configuration/mgmt-users.properties] is not readable.

Expected results:
No warnings.

Additional info:
This is because JBoss EAP's users, groups, and roles configuration files are read/write by owner only. Meaning that the jbossadmin user owns these files and the jbossonadmin user does not have permission to read these files.

The plug-in should not log this warning. Perhaps it can capture this at debug or trace logging?

Comment 1 Jay Shaughnessy 2014-07-28 18:43:41 UTC
master commit 58b6ff04c2451646b7b78c76a0bc98c030b1e6bd
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Jul 28 14:39:30 2014 -0400

    Converted to debug level logging


release/jon3.3.x commit b2eb374692b06340cae871a1240730261deea6ad
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Jul 28 14:42:02 2014 -0400

    Cherry-pick master 03db180e7fbe8e9867552f6aceafaa653b4c369d

Comment 2 Simeon Pinder 2014-07-31 15:52:19 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993


Note You need to log in before you can comment on or make changes to this bug.