Bug 1118078 - Deployment UI does not explain errors behind "unassigned host" message.
Summary: Deployment UI does not explain errors behind "unassigned host" message.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z1
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 00:30 UTC by Lars Kellogg-Stedman
Modified: 2014-10-01 13:25 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.3.4-2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, some error messages simply displayed 'Unassigned Host' with no other details. This made debugging an issue. With this update, a more useful error message is displayed and users should have a better idea of the problem is immediately when using the UI.
Clone Of:
Environment:
Last Closed: 2014-10-01 13:25:11 UTC


Attachments (Terms of Use)
screenshot of "error" message. (8.66 KB, image/png)
2014-07-10 00:30 UTC, Lars Kellogg-Stedman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Lars Kellogg-Stedman 2014-07-10 00:30:11 UTC
Created attachment 916966 [details]
screenshot of "error" message.

There are a variety of problems that can result in failures when one tries to assign hosts to a deployment role in the installer.  In all cases, the web ui responds by raising a popup window on the screen that says, "Unassigned hosts: <hostname1>, ..., <hostnameN>" (see screenshot in attachment).

There is no indication there was an actual error, and the only way to find out what happened is to peruse the Foreman log in /var/log/foreman/production.log.

Errors in this log are not always clearly delineated or easy to find.  For example, at the moment I am seeing this error after deleting a deployment and creating a new one.  In the log I see:

525400fea25a (Name has already been taken,IP address has already been taken,MAC address has already been taken)
525400380440 (Name has already been taken,IP address has already been taken,MAC address has already been taken)
525400fef618 (Name has already been taken,IP address has already been taken,MAC address has already been taken)

...but if I wasn't tailing the log at the time of this issue, those messages would be hard to find in the chatter that Foreman regularly logs.  There is no "ERROR" prefix that could be used to find them.

Fundamentally, these errors should percolate to the web UI and should be displayed to the user.  Anything else is going to result in an incredibly frustrating user experience.

Comment 4 Alexander Chuzhoy 2014-09-16 15:03:40 UTC
Verified:rhel-osp-installer-0.3.4-3.el6ost.noarch

Had an error and in addition to:
"Unassigned hosts:
    <hostname>"

It also shows the reason:
Name has already been taken. The whole message looks as following:


Unassigned hosts:

    <hostname>
        Name has already been taken

Comment 6 errata-xmlrpc 2014-10-01 13:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.