Bug 1118118 - killer.pl should die quietly if shutdownhtml is set
Summary: killer.pl should die quietly if shutdownhtml is set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Database
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 4.4
Assignee: Matt Tyson 🤬
QA Contact: Simon Green
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 03:01 UTC by Simon Green
Modified: 2018-12-09 06:29 UTC (History)
4 users (show)

Fixed In Version: 4.4.4022
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 00:43:04 UTC


Attachments (Terms of Use)

Description Simon Green 2014-07-10 03:01:40 UTC
Description of problem:
With today's Bugzilla outage, killer.pl decided it was a good time to spam us.

Version-Release number of selected component (if applicable):
4.4.4021-5

How reproducible:
always.

Steps to Reproduce:
1. Set shutdownhtml
2. Run killer.pl

Actual results:
Receive output similar to: "This service is presently offline for maintenance commencing 2014-07-09 22:01:11 EDT lasting 10 minutes Log4perl: Seems like no initialization happened. Forgot to call init()?"

Expected results:
Exits silently

Additional info:

Comment 1 Matt Tyson 🤬 2014-07-10 04:52:28 UTC
The easiest way to fix this is to rename the script to rh-killer.pl.  This will allow it to be run without generating errors while shutdownhtml is set.

Comment 2 Simon Green 2014-07-19 04:42:21 UTC
Cannot be verified on bzweb01-devel.app.eng.rdu.redhat.com due to its configuration.

  -- simon

Comment 3 Matt Tyson 🤬 2014-07-28 00:43:04 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.