Bug 1118186 - Should left-aligned the ovirt-node-plugin-vdsm package info in plugin page
Summary: Should left-aligned the ovirt-node-plugin-vdsm package info in plugin page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 07:29 UTC by wanghui
Modified: 2016-07-04 00:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:59:34 UTC
oVirt Team: Node


Attachments (Terms of Use)
ovirt-node-plugin-vdsm info shows in plugin page (8.86 KB, image/png)
2014-07-10 07:29 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 29831 master MERGED plugins_page:Avoid a newline for plugins name/version/data installed info Never

Description wanghui 2014-07-10 07:29:49 UTC
Created attachment 917003 [details]
ovirt-node-plugin-vdsm info shows in plugin page

Description of problem:
It should be better to left-aligned the ovirt-node-plugin-vdsm package info in plugin page.

This issue may caused by following code in plugins_page.py.
cmd = "rpm -q %s --qf 'NAME: %s DATE: \
       %%{version}-%%{release}.%%{arch} INST: \
       %%{INSTALLTIMEate}\\n'" %\
       (package, package)

It should be changed as follows.
cmd = "rpm -q %s --qf 'NAME: %s DATE: " \
      "%%{version}-%%{release}.%%{arch} INST: " \
      "%%{INSTALLTIMEate}\\n'" % (package, package)

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20140624.0.el6ev
ovirt-node-3.0.1-18.el6_5.11.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install rhev-hypervisor6-6.5-20140624.0.el6ev
2. Check the ovirt-node-plugin-vdsm info in plugin page

Actual results:
1. The ovirt-node-plugin-vdsm details in plugin page is not arranged perfectly.

Expected results:
1. The ovirt-node-plugin-vdsm details in plugin page should display as left-aligned without blank space in front of it.

Additional info:

Comment 1 Fabian Deutsch 2014-09-02 18:29:13 UTC
Douglas, please review the patch and merge if it suites your requirements.

Comment 3 wanghui 2014-12-18 05:11:53 UTC
Test Version:
rhev-hypervisor6-6.6-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el6.noarch

Test step:
1. Clear install rhev-hypervisor6-6.6-20141212.0.iso
2. Check the ovirt-node-plugin-vdsm info in plugin page

Test result:
1. After step2, the ovirt-node-plugin-vdsm details in plugin page display as left-aligned.

So this issue is fixed in rhev-hypervisor6-6.6-20141212.0.iso. Also this issue not exists in rhev-hypervisor7-7.0-20141212.0.iso. Change the status from ON_QA to Verified.

Comment 5 errata-xmlrpc 2015-02-11 20:59:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.