Bug 1118239 - JDBC drivers are listed incorrectly in domain mode
Summary: JDBC drivers are listed incorrectly in domain mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: DR5
: EAP 6.4.0
Assignee: Harald Pehl
QA Contact: Pavel Jelinek
URL:
Whiteboard:
: 1117785 1142571 (view as bug list)
Depends On: JBPAPP6-1441 1117785
Blocks: 1148709 1150937
TreeView+ depends on / blocked
 
Reported: 2014-07-10 09:32 UTC by Jakub Cechacek
Modified: 2019-08-19 12:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-483 Critical Resolved JDBC drivers are listed incorrectly in domain mode 2018-11-13 11:18:03 UTC

Description Jakub Cechacek 2014-07-10 09:32:32 UTC
Currently when creating a new datasource in domain mode only jdbc drivers available to running servers are listed (BZ1117785)

This causes several issues.

1) For every profile drivers available to all servers are listed (even those running with different profile). This will allow user to create a datasource with driver which might not be available in given profile. For more info and reproducer relate to BZ1117785

2) consequence of BZ900675 -- If there is no server running with given profile, user won't be able to see available drivers

3)consequence of BZ1117785 -- If the same driver is configured in 2 different profiles, it will be listed twice when creating a new datasource (provided that there is a running server with each of these profiles)

Comment 2 Heiko Braun 2014-09-18 11:59:54 UTC
*** Bug 1142571 has been marked as a duplicate of this bug. ***

Comment 3 JBoss JIRA Server 2014-10-07 10:37:10 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-483 to Coding In Progress

Comment 4 JBoss JIRA Server 2014-10-07 19:39:20 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-483 to Resolved

Comment 5 Heiko Braun 2014-10-08 06:39:17 UTC
*** Bug 1117785 has been marked as a duplicate of this bug. ***

Comment 6 Kabir Khan 2014-10-09 19:05:38 UTC
Fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1118239

Comment 7 Jakub Cechacek 2014-11-14 09:59:39 UTC
Verified 6.4.0.DR9


Note You need to log in before you can comment on or make changes to this bug.