Bug 1118248 - bibletime build fails on s390
Summary: bibletime build fails on s390
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bibletime
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 09:44 UTC by Jakub Čajka
Modified: 2014-07-19 05:58 UTC (History)
2 users (show)

Fixed In Version: bibletime-2.10.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-19 05:58:27 UTC


Attachments (Terms of Use)
Patch resolving this bug (2.30 KB, patch)
2014-07-10 09:44 UTC, Jakub Čajka
no flags Details | Diff

Description Jakub Čajka 2014-07-10 09:44:14 UTC
Created attachment 917032 [details]
Patch resolving this bug

Build fails on s390 with ld error. It seems to be caused by -fpie gcc flag. Replacing -fpie with -fPIE makes build succeed. Also according to the Fedora packaging guidelines package should use -fPIE/-fPIC flag.

https://fedoraproject.org/wiki/Packaging:Guidelines#PIE

In attachment is patch doing this change. Patched package build successfully on all archs.

Build links:
http://koji.fedoraproject.org/koji/taskinfo?taskID=7122526
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2485642
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1939430
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1437345

Original failing build:
http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=253753

Comment 1 greg.hellings 2014-07-10 13:40:01 UTC
I have submitted the patch upstream and am proceeding with building the package with the attached patch.

Comment 2 greg.hellings 2014-07-10 13:40:23 UTC
Upstream pull request: https://github.com/bibletime/bibletime/pull/8

Comment 3 Fedora Update System 2014-07-10 15:00:03 UTC
bibletime-2.10.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bibletime-2.10.1-2.fc20

Comment 4 Fedora Update System 2014-07-11 02:04:15 UTC
Package bibletime-2.10.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bibletime-2.10.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8252/bibletime-2.10.1-2.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-07-19 05:58:27 UTC
bibletime-2.10.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.