Bug 1118309 - Documentation tracker bug
Summary: Documentation tracker bug
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 12:16 UTC by Pranith Kumar K
Modified: 2018-08-29 03:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:53:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2014-07-10 12:16:38 UTC
Description of problem:
I wanted to document the core data structres and debugging infra in gluster. This bug will be tracking these changes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-07-10 12:20:25 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2014-07-14 15:20:12 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2014-07-14 15:34:09 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2014-07-17 06:40:59 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Anand Avati 2014-07-17 17:25:48 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Pranith Kumar K 2014-07-22 08:34:35 UTC
More people from community volunteered to document the data-structures.
Here is the list at the moment:
https://etherpad.wikimedia.org/p/glusterdoc
client_t                                         - Pranith
integration with statedump        - Pranith        http://review.gluster.org/#/c/8288/
mempool                                     - Pranith
event-history + circ-buff             - Raghavendra Bhat
inode                                           - Raghavendra Bhat
call-stub                                       - Krutika
fd                                                  - JDarcy (?)
iobuf                                              - Poornima
graph                                             - JDarcy/ Kaushal(?)
xlator                                              - JDarcy
option-framework                        - Kaushal
rbthash                                          -                                                 
runner-framework                        - Raghavendra G (?)
stack/frame                                   - JDarcy
strfd                                                 -   
timer                                                - Krutika
store                                                - Niels
dict                                                  - JDarcy/ Kaushal (?)
event-poll                                        - Ravi
syncop-framework                          -Raghavendra G
gid-cache(source is heavily documented)

Comment 7 Anand Avati 2014-07-22 08:35:43 UTC
REVIEW: http://review.gluster.org/8343 (doc: mem-pool documentation) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 8 Anand Avati 2014-07-22 08:53:01 UTC
REVIEW: http://review.gluster.org/8343 (doc: mem-pool documentation) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 9 Anand Avati 2014-07-22 09:23:57 UTC
REVIEW: http://review.gluster.org/8343 (doc: mem-pool documentation) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Anand Avati 2014-07-22 14:29:33 UTC
REVIEW: http://review.gluster.org/8348 (doc: Better organization for code documentation) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

Comment 11 Anand Avati 2014-07-22 14:29:42 UTC
REVIEW: http://review.gluster.org/8349 (doc: Documentation for translator options framework.) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

Comment 12 Anand Avati 2014-07-22 14:34:09 UTC
REVIEW: http://review.gluster.org/8348 (doc: Better organization for code documentation) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)

Comment 13 Anand Avati 2014-07-22 14:34:18 UTC
REVIEW: http://review.gluster.org/8349 (doc: Documentation for translator options framework.) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)

Comment 14 Anand Avati 2014-07-23 09:13:41 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 15 Anand Avati 2014-07-23 09:44:09 UTC
REVIEW: http://review.gluster.org/8343 (doc: mem-pool documentation) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 16 Anand Avati 2014-07-23 09:46:13 UTC
REVIEW: http://review.gluster.org/8343 (doc: mem-pool documentation) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 17 Anand Avati 2014-07-23 10:35:38 UTC
REVIEW: http://review.gluster.org/8288 (doc: How to generate and read statedump) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 18 Anand Avati 2014-07-23 12:56:58 UTC
REVIEW: http://review.gluster.org/8364 (doc: afr-locking) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 19 Anand Avati 2014-07-23 12:59:04 UTC
REVIEW: http://review.gluster.org/8364 (doc: afr-locking) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 20 Anand Avati 2014-07-24 07:17:26 UTC
REVIEW: http://review.gluster.org/8364 (doc: afr-locks and its evolution) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 21 Anand Avati 2014-07-27 20:35:57 UTC
COMMIT: http://review.gluster.org/8288 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 7b7f8533331f9478724e226a9c3a4a34dfe11228
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Jul 9 17:31:52 2014 +0530

    doc: How to generate and read statedump
    
    Thanks to Poornima G's help with iobuf
    Section explanation.
    
    Change-Id: I17737fdbd1f402914f7e67fb4047f5c26ea5c36c
    BUG: 1118309
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/8288
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 22 Anand Avati 2014-08-01 07:54:15 UTC
COMMIT: http://review.gluster.org/8343 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 590006d824f4051acdccbe59415fc4772e3caa2f
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Jul 15 21:45:35 2014 +0530

    doc: mem-pool documentation
    
    Change-Id: I9bc454c92a078de5e3a30372a50c6f2cbdcd6c21
    BUG: 1118309
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/8343
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 23 Anand Avati 2014-08-05 10:45:00 UTC
COMMIT: http://review.gluster.org/8364 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit ef60640dfab44a53083a717bb4ee1386f8baad92
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Jul 23 18:24:55 2014 +0530

    doc: afr-locks and its evolution
    
    History and current state of how AFR uses the inode and entry locks
    provided by the locks xlator
    
    Thanks to Pranith for patiently explaining this.
    
    Change-Id: I25d21c6361e95aa0b3edcffe9b3b9e470f488bc6
    BUG: 1118309
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/8364
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 24 Anand Avati 2014-09-23 09:35:52 UTC
REVIEW: http://review.gluster.org/8818 (doc: iobuf and iobref documentation.) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

Comment 25 Anand Avati 2014-09-23 09:38:52 UTC
REVIEW: http://review.gluster.org/8818 (doc: iobuf and iobref documentation.) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 26 Anand Avati 2014-10-01 06:02:19 UTC
REVIEW: http://review.gluster.org/8818 (doc: iobuf and iobref documentation.) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 27 Anand Avati 2014-10-08 12:51:54 UTC
REVIEW: http://review.gluster.org/8818 (doc: iobuf and iobref documentation.) posted (#4) for review on master by Poornima G (pgurusid@redhat.com)

Comment 28 Anand Avati 2014-10-29 17:49:46 UTC
COMMIT: http://review.gluster.org/8818 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 20efa36ed961a210cfc2cec7599acf92cec157ce
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Sep 23 14:56:40 2014 +0530

    doc: iobuf and iobref documentation.
    
    Change-Id: Ib6d8121a968e8160c587a8553b7333262bb44975
    BUG: 1118309
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/8818
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 29 Anand Avati 2015-01-15 12:53:28 UTC
REVIEW: http://review.gluster.org/9456 (doc: afr self-heal daemon) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 30 Anand Avati 2015-01-29 05:55:05 UTC
REVIEW: http://review.gluster.org/9456 (doc: self-heal daemon) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 31 Anand Avati 2015-01-29 07:07:59 UTC
REVIEW: http://review.gluster.org/9456 (doc: self-heal daemon) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 32 Anand Avati 2015-02-02 13:02:25 UTC
REVIEW: http://review.gluster.org/9537 (doc: self-heal daemon) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 33 Anand Avati 2015-02-02 20:16:21 UTC
REVIEW: http://review.gluster.org/9537 (doc: self-heal daemon) posted (#22) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 34 Anand Avati 2015-02-02 20:16:37 UTC
COMMIT: http://review.gluster.org/9537 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 70b72316302b017436b44a58aa025dabd3558ae7
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Sun Feb 1 12:40:21 2015 +0000

    doc: self-heal daemon
    
    Documentation describing how the self-heal daemon works for replicate
    volumes.
    
    Change-Id: I89bdbbeee7f5106f0ee71870e11aa9c96f90753d
    BUG: 1118309
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/9537
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>

Comment 35 Amar Tumballi 2018-08-29 03:53:48 UTC
Lot of time since no activity on this bug. We have either fixed it already or it is mostly not critical anymore!

Please re-open the bug if the issue is burning for you, or you want to take the bug to closure with fixes.


Note You need to log in before you can comment on or make changes to this bug.