Bug 111831 - Install fails after download stage2
Install fails after download stage2
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-12-10 13:22 EST by Stefan Llewellyn Smith
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-05 11:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/sbin/lspci -v for the machine in question (4.54 KB, text/plain)
2003-12-10 13:23 EST, Stefan Llewellyn Smith
no flags Details

  None (edit)
Description Stefan Llewellyn Smith 2003-12-10 13:22:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)

Description of problem:
I'm trying to upgrade a laptop from RH9 to Fedora using an FTP
install. I download stage2.img from the ftp site and then anaconda
falls over.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot from bootdisk.img, choose ftp intall, and insert driver disk
2. enter ip and ftp information
3. watch stage2.img download


Actual Results:  Crash with following message:

error 2 reading header: cpio: Bad magic

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 341, in ?
    import signal, traceback, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.ps", line 22, in ?
    from rhpl.log import log
ImportError: No module named rhpl.log
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap..
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /tmp/ramfs done
you may safely reboot your system

Expected Results:  Continue with install

Additional info:

I've also tried this with linux -noprobe. I have to pick the
appropriate driver for the ethernet (3c59x). Stage2.img downloads OK
then I get a message:

The following devices have been found on your system
3Com ... (3c59x)
with options "Done" and "Add Device". I've already added this device
and if I choose "Add Device", the 3c59x driver is gone. So I choose
"Done" and get the same error as above.
Comment 1 Stefan Llewellyn Smith 2003-12-10 13:23:37 EST
Created attachment 96450 [details]
/sbin/lspci -v for the machine in question
Comment 2 Jeremy Katz 2003-12-16 19:54:37 EST
This sounds like bits got scrambled in transit -- is it reproducible?
 If so, does memtest86 show any problems with your machine?
Comment 3 Stefan Llewellyn Smith 2003-12-17 19:40:31 EST
This is reproducible. No errors in memtest86. The same thing happens
booting off a CD. But only when downloading the image from
linux.stanford.edu. Using mirrors.kernel.org works just fine. I should
have tried another image.

Trying to install from iso images off the hard disk fails after
entering the location of the images. Don't know what that's about.

This suggests there's something wrong with the image at

Comment 4 Jeremy Katz 2004-10-05 11:47:51 EDT
This looks like it was a mirror problem and hasn't resurfaced with
newer releases.

Note You need to log in before you can comment on or make changes to this bug.