Bug 1118324 - PackageKit: lr_handle_setopt(): packagekitd killed by SIGSEGV during yum update
Summary: PackageKit: lr_handle_setopt(): packagekitd killed by SIGSEGV during yum update
Keywords:
Status: CLOSED DUPLICATE of bug 1146555
Alias: None
Product: Fedora
Classification: Fedora
Component: librepo
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tomas Mlcoch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 12:54 UTC by Mikko Tiihonen
Modified: 2014-12-03 12:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-03 12:10:32 UTC


Attachments (Terms of Use)
manually generated backtrace (10.39 KB, text/plain)
2014-07-10 12:54 UTC, Mikko Tiihonen
no flags Details
core_backtrace (8.09 KB, text/plain)
2014-07-10 12:55 UTC, Mikko Tiihonen
no flags Details
var_log_messages (5.56 KB, text/plain)
2014-07-10 12:55 UTC, Mikko Tiihonen
no flags Details

Description Mikko Tiihonen 2014-07-10 12:54:33 UTC
Created attachment 917055 [details]
manually generated backtrace

During yum update the package kit daemon segfaulted.

I attached manually generated backtrace and some abrt generated files.

---

Unrelated to this bugreport:
Abrt won't accept the bug report (Server responded with an error: 'Validation failed: Element 'stacktrace' is invalid: List element is invalid: Element 'frames' is invalid: List element is invalid: Element 'file_name' is missing') since the librepo.so.0 file was modified as part of the update from 1.7.4-3 to 1.7.5-1.

Comment 1 Mikko Tiihonen 2014-07-10 12:55:21 UTC
Created attachment 917056 [details]
core_backtrace

Comment 2 Mikko Tiihonen 2014-07-10 12:55:59 UTC
Created attachment 917057 [details]
var_log_messages

Comment 3 Kalev Lember 2014-10-05 19:16:53 UTC
Looks like a librepo crash. Reassigning.

Comment 4 Tomas Mlcoch 2014-12-03 12:10:32 UTC

*** This bug has been marked as a duplicate of bug 1146555 ***


Note You need to log in before you can comment on or make changes to this bug.