Bug 1118330 - pki customization on separate hosts is unforgiving
Summary: pki customization on separate hosts is unforgiving
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-reports
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: movciari
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 13:03 UTC by Yedidyah Bar David
Modified: 2014-12-15 15:07 UTC (History)
9 users (show)

Fixed In Version: oVirt-3.5 GA ovirt-engine-reports-3.5.0-1.fc19.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:30:26 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32385 master MERGED packaging: setup: Make pki interaction easier Never
oVirt gerrit 33139 ovirt-engine-reports-3.5 MERGED packaging: setup: Make pki interaction easier Never

Description Yedidyah Bar David 2014-07-10 13:03:22 UTC
Description of problem:

When setting up Reports on a separate host from the engine, user is asked for pki stuff (copy csr to ca, copy back cert). Any single error in these interactions aborts setup and the user has to start from the beginning. We should try instead to check for errors and query again for new input as applicable.

Version-Release number of selected component (if applicable):

current master

How reproducible:

Always

Steps to Reproduce:
1. setup engine
2. setup reports on a separate host
3. during (2.) do some mistake - e.g. copy/paste cert dropping lines or whatever

Actual results:

setup aborts

Expected results:

setup prompts again

Additional info:

Comment 1 Yaniv Lavi 2014-09-21 10:48:17 UTC
Is this fixed in:
http://gerrit.ovirt.org/#/c/33139/ ?



yaniv

Comment 2 Yedidyah Bar David 2014-09-21 11:30:38 UTC
Yes...

Comment 3 movciari 2014-10-09 09:57:04 UTC
this is obsolete now, because now you don't do copy-paste when installing reports, you copy files so you don't miss lines, right?

Comment 4 Yedidyah Bar David 2014-10-12 06:52:46 UTC
(In reply to movciari from comment #3)
> this is obsolete now, because now you don't do copy-paste when installing
> reports, you copy files so you don't miss lines, right?

You could in principle provide a wrong file name/permissions/content/whatever - you'll now be prompted again.

Comment 5 Sandro Bonazzola 2014-10-17 12:30:26 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.