Bug 1118338 - [RFE] Remove the "Destroy" menu item from the contextual menu
Summary: [RFE] Remove the "Destroy" menu item from the contextual menu
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Nobody
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 13:08 UTC by Ori Gofen
Modified: 2016-08-02 16:25 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-20 18:46:11 UTC
oVirt Team: Storage
blackfede: needinfo-
ylavi: ovirt-4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
image (24.06 KB, image/png)
2014-07-10 13:08 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-07-10 13:08:42 UTC
Created attachment 917070 [details]
image

Description of problem:
Destroy domain operation is only available when right clicking the mouse while above the chosen domain and should be also available as a button (see image)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Allon Mureinik 2014-07-10 18:24:10 UTC
Frankly, I don't think it should be in the context menu either - this should be an external utility, not part of the GUI.

Comment 2 Aharon Canan 2015-04-26 12:58:17 UTC
Sounds like we need it open anyway, 

In case of adding it or like allon wrote in comment#1 removing it from context menu,

Yaniv/Scott - Please advice.

Comment 3 Yaniv Lavi 2015-04-29 21:40:34 UTC
For 3.6 we won't change this, we can consider this for future versions.

Comment 4 Nir Soffer 2015-08-20 22:16:43 UTC
We consider the Destory menu item as a bug, so the only purpose of this but
can be to remove it. I update the title to reflect this.

Comment 5 Red Hat Bugzilla Rules Engine 2015-12-01 15:25:48 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 6 Allon Mureinik 2016-01-20 17:35:47 UTC
I don't see the point in investing in the vintage GUI in this point - please consider closing this.

Comment 7 Yaniv Kaul 2016-01-20 18:46:11 UTC
(In reply to Allon Mureinik from comment #6)
> I don't see the point in investing in the vintage GUI in this point - please
> consider closing this.

OK, it's a minor issue anyway.

Comment 8 Federico Fortini 2016-07-14 14:32:36 UTC
Hello everyone. I've yust see this old bug because i see the same discrepancy reported from the OP.

Honestly i can't sse the poit in removing the "destroy" button from te GUI. I think the usability can increase if the option of removing a domain is present in the WebInterface instead of some command to be executed from the shell on the engine server.

In any case, if i ADD a new domain from the WebAdmin interface, why i should remove in a different way?

Comment 9 Yaniv Lavi 2016-07-17 12:24:45 UTC
Destroy is not remove. You can remove a domain, but destroy can have a unexpected result.


Note You need to log in before you can comment on or make changes to this bug.