Bug 1118352 - initscript unaware of uprobes
Summary: initscript unaware of uprobes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Martin Cermak
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 13:33 UTC by Frank Ch. Eigler
Modified: 2015-07-22 06:44 UTC (History)
5 users (show)

(edit)
Previously, some startup-time scripts required the "uprobes.ko" module built, installed, or loaded, but the init script did not identify whether and how to do so. A patch has been applied to fix this bug, and the init script now performs the appropriate operations.
Clone Of:
(edit)
Last Closed: 2015-07-22 06:44:59 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1333 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2015-07-20 18:00:10 UTC

Description Frank Ch. Eigler 2014-07-10 13:33:42 UTC
Some startup-time scripts may need uprobes.ko build/installed/loaded on RHEL<7, but the initscript doesn't know to whether/how to do this.

Comment 1 Stefan Hajnoczi 2014-08-08 06:55:26 UTC
Patches posted upstream:
https://sourceware.org/ml/systemtap/2014-q3/msg00133.html

Comment 6 Martin Cermak 2015-04-15 18:55:27 UTC
Reproduced with systemtap-2.5-5.el6:

===== 
[root@dell-per320-01 script.d]# cat tracels.stp 
probe process("/bin/ls").function("main") {println(pp(), "blah ")}
[root@dell-per320-01 script.d]#
[root@dell-per320-01 script.d]# service systemtap start
Starting systemtap:  Compiling tracels ... done
 Starting tracels ... error
[FAILED]
===== 

Plus Console output is

=====
tracels: Unknown symbol register_uprobe
tracels: Unknown symbol unmap_uretprobe
tracels: Unknown symbol register_uretprobe
tracels: Unknown symbol unmap_uprobe
tracels: Unknown symbol unregister_uprobe
=====

Verified with systemtap-2.7-2.el6.

Comment 7 errata-xmlrpc 2015-07-22 06:44:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1333.html


Note You need to log in before you can comment on or make changes to this bug.