Bug 1118355 - soffice.bin killed by SIGSEGV
Summary: soffice.bin killed by SIGSEGV
Keywords:
Status: CLOSED DUPLICATE of bug 1115472
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:bcb5ac609390779a8c74fe142f3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 13:48 UTC by David Jaša
Modified: 2014-07-10 13:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 13:53:23 UTC


Attachments (Terms of Use)
File: backtrace (50.39 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: cgroup (172 bytes, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: core_backtrace (26.25 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: dso_list (22.14 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: environ (1.87 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: limits (1.29 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: maps (106.52 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: open_fds (604 bytes, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: proc_pid_status (1.08 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: var_log_messages (1.25 KB, text/plain)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: binary (6.98 KB, application/octet-stream)
2014-07-10 13:48 UTC, David Jaša
no flags Details
File: sosreport.tar.xz (7.19 MB, application/octet-stream)
2014-07-10 13:49 UTC, David Jaša
no flags Details

Description David Jaša 2014-07-10 13:48:38 UTC
Version-Release number of selected component:
libreoffice-core-4.1.4.2-3.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: Image::GetSizePixel
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.10.0-123.1.2.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            16189

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 Image::GetSizePixel at /usr/src/debug/libreoffice-4.1.4.2/vcl/source/gdi/image.cxx:191
 #1 sd::OutlineView::PaintingFirstLineHdl at /usr/src/debug/libreoffice-4.1.4.2/sd/source/ui/view/outlview.cxx:1724
 #2 Call at /usr/src/debug/libreoffice-4.1.4.2/include/tools/link.hxx:123
 #3 OutlinerEditEng::PaintingFirstLine at /usr/src/debug/libreoffice-4.1.4.2/editeng/source/outliner/outleeng.cxx:52
 #4 ImpEditEngine::Paint at /usr/src/debug/libreoffice-4.1.4.2/editeng/source/editeng/impedit3.cxx:2950
 #6 EditView::Paint at /usr/src/debug/libreoffice-4.1.4.2/editeng/source/editeng/editview.cxx:296
 #7 OutlinerView::Paint at /usr/src/debug/libreoffice-4.1.4.2/editeng/source/outliner/outlvw.cxx:82
 #8 sd::OutlineView::Paint at /usr/src/debug/libreoffice-4.1.4.2/sd/source/ui/view/outlview.cxx:237
 #9 sd::OutlineViewShell::Paint at /usr/src/debug/libreoffice-4.1.4.2/sd/source/ui/view/outlnvsh.cxx:258
 #10 Window::ImplCallPaint at /usr/src/debug/libreoffice-4.1.4.2/vcl/source/window/window.cxx:2470

Comment 1 David Jaša 2014-07-10 13:48:40 UTC
Created attachment 917085 [details]
File: backtrace

Comment 2 David Jaša 2014-07-10 13:48:42 UTC
Created attachment 917086 [details]
File: cgroup

Comment 3 David Jaša 2014-07-10 13:48:43 UTC
Created attachment 917087 [details]
File: core_backtrace

Comment 4 David Jaša 2014-07-10 13:48:45 UTC
Created attachment 917088 [details]
File: dso_list

Comment 5 David Jaša 2014-07-10 13:48:46 UTC
Created attachment 917089 [details]
File: environ

Comment 6 David Jaša 2014-07-10 13:48:47 UTC
Created attachment 917090 [details]
File: limits

Comment 7 David Jaša 2014-07-10 13:48:49 UTC
Created attachment 917091 [details]
File: maps

Comment 8 David Jaša 2014-07-10 13:48:51 UTC
Created attachment 917092 [details]
File: open_fds

Comment 9 David Jaša 2014-07-10 13:48:52 UTC
Created attachment 917093 [details]
File: proc_pid_status

Comment 10 David Jaša 2014-07-10 13:48:53 UTC
Created attachment 917094 [details]
File: var_log_messages

Comment 11 David Jaša 2014-07-10 13:48:54 UTC
Created attachment 917095 [details]
File: binary

Comment 12 David Jaša 2014-07-10 13:49:26 UTC
Created attachment 917096 [details]
File: sosreport.tar.xz

Comment 13 David Jaša 2014-07-10 13:53:23 UTC
The crash occurred exactly as in bug 1115472 and even the backtrace looks the same apart from last two frames (indicating some memory corruption?).

*** This bug has been marked as a duplicate of bug 1115472 ***


Note You need to log in before you can comment on or make changes to this bug.