Bug 1118365 - No debug output
Summary: No debug output
Keywords:
Status: CLOSED DUPLICATE of bug 1107518
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 14:12 UTC by Tomas Jamrisko
Modified: 2014-07-23 17:02 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.6.0-10.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 17:02:35 UTC


Attachments (Terms of Use)
Log from client (692.25 KB, text/plain)
2014-07-10 14:44 UTC, Tomas Jamrisko
no flags Details

Description Tomas Jamrisko 2014-07-10 14:12:47 UTC
Description of problem:
Volume on the client gets increase after migration gets successfully completed

Version-Release number of selected component (if applicable):
virt-viewer-0.6.0-9.el6
spice-gtk-0.22-7.el6


How reproducible:
100%

Steps to Reproduce:
1. Connect to a Windows guest (tried this using rhevm3.4)
2. Play something on the guest
3. Lower volume on client
4. Migrate the guest to a different host

Actual results:
Playback volume gets increased

Comment 1 Marc-Andre Lureau 2014-07-10 14:16:19 UTC
there is already a similar bug open, and it is some ac97 qemu bug iirc.

Could you attach SPICE_DEBUG=1 log when migration occurs 

Can you verify which audio device is used by guest?

thanks

Comment 2 Marc-Andre Lureau 2014-07-10 14:21:08 UTC
also it could be a dup of bug 1012868

Comment 4 Tomas Jamrisko 2014-07-10 14:44:40 UTC
Created attachment 917120 [details]
Log from client

This is the requested log file.

The audio device on guest is intel-hda, not AC97.
Bug present also in RHEL7. 

Also, the log file was taken with spice-gtk3-0.20-8.el7.x86_64 and RHEL7 client, hope you don't mind. As there was no debug console output with spice-gtk-0.22-7 and virt-viewer 0.6.0-9 on RHEL6...

Comment 5 Tomas Jamrisko 2014-07-10 14:49:30 UTC
Also, yes, it's possibly a duplicate (quick search didn't show anything)

Comment 6 Marc-Andre Lureau 2014-07-10 14:50:35 UTC
(In reply to Tomas Jamrisko from comment #4)
> Created attachment 917120 [details]
> Log from client
> 
> This is the requested log file.
> 
> The audio device on guest is intel-hda, not AC97.
> Bug present also in RHEL7. 

Ok, from the log the volume didn't change, it's always 60138. 

How do you change the volume of the client? via client master volume? then it's a dup  of bug 1012868

> Also, the log file was taken with spice-gtk3-0.20-8.el7.x86_64 and RHEL7
> client, hope you don't mind. As there was no debug console output with
> spice-gtk-0.22-7 and virt-viewer 0.6.0-9 on RHEL6...

What do you mean? SPICE_DEBUG=1 didn't work? strange that works for me. Looks like you may have old spice-gtk with new glib, that requires G_MESSAGES_DEBUG=all

Comment 7 Tomas Jamrisko 2014-07-10 15:06:34 UTC
G_MESSAGES_DEBUG=all doesn't work either, neither does --spice-debug
versions: spice-gtk-0.22-7, which is in errata for 6.6
spice-glib is the same, 0.22-7,

Comment 8 Marc-Andre Lureau 2014-07-10 16:11:22 UTC
(In reply to Tomas Jamrisko from comment #7)
> G_MESSAGES_DEBUG=all doesn't work either, neither does --spice-debug
> versions: spice-gtk-0.22-7, which is in errata for 6.6
> spice-glib is the same, 0.22-7,

you need both G_MESSAGES_DEBUG=all and SPICE_DEBUG=1

What is glib version?

Comment 9 Marc-Andre Lureau 2014-07-10 20:39:40 UTC

*** This bug has been marked as a duplicate of bug 1012868 ***

Comment 10 Tomas Jamrisko 2014-07-11 08:23:03 UTC
glibc-2.12-1.147
glib2-2.28.8-1

And there still isn't any debugging output, even with both of those env variables set.

Comment 11 Tomas Jamrisko 2014-07-11 09:42:34 UTC
Reopening, and "repurposing" for missing debug output introduced by rebase.

Comment 12 Marc-Andre Lureau 2014-07-11 09:54:37 UTC
most likely I forgot v0.6.0-50-g48d8fa7

Comment 13 Marc-Andre Lureau 2014-07-11 10:02:34 UTC
virt-viewer filters out debug messages with glib < 2.32, unless you run with --debug (see bug 1107518).

we could make it filter only its own messages instead..

Comment 15 Marc-Andre Lureau 2014-07-16 17:33:35 UTC
this a regression from 1107518, I am tempted to push the fix and mark as duplicate. please ack otherwise.

Comment 16 Marc-Andre Lureau 2014-07-21 09:07:47 UTC
Jonathon, Christophe, can you ack the patch for RHEL6 only atm? thanks

As I explained in ML, Christophe G_MESSAGES_DEBUG patch doesn't solve this bug, and is a change of logging behaviour compared to other rhel6 apps. It's also the wrong place to backport imho.

Comment 17 Jonathon Jongsma 2014-07-21 15:56:06 UTC
Clearing needinfo as I replied on email list: https://www.redhat.com/archives/virt-tools-list/2014-July/msg00080.html

Comment 18 Marc-Andre Lureau 2014-07-23 17:02:35 UTC
push fix as regression of 1107518

*** This bug has been marked as a duplicate of bug 1107518 ***


Note You need to log in before you can comment on or make changes to this bug.