Bug 1118369 - RHEV 3.4 versioned templates are indistinguishable
Summary: RHEV 3.4 versioned templates are indistinguishable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom Caspy
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 14:22 UTC by Maxim Burgerhout
Modified: 2016-07-27 08:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:16 UTC


Attachments (Terms of Use)
versioned templates are indistinguishable (44.03 KB, image/png)
2016-04-20 16:23 UTC, Kedar Bidarkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 6568 None None None 2016-04-22 15:46:59 UTC

Description Maxim Burgerhout 2014-07-10 14:22:57 UTC
Description of problem:
RHEV 3.4 allows for the creation of versioned templates, i.e. multiple templates with the same name, but a different version number. For version > 1 of a template, the API returns XML describing the template, including a stanza like:

        <version>
            <base_template href="/api/templates/857cd7ce-3461-4eb5-9acb-7a49404ec2f7" id="857cd7ce-3461-4eb5-9acb-7a49404ec2f7"/>
            <version_number>2</version_number>
            <version_name>enabled cloudinit</version_name>
        </version>

In my RHEV 3.4 setup, I have multiple versions of a template called 'vm_template'. When creating a new image under my RHEV compute resource, all these templates show up as just 'vm_template' in the 'image' selector field (which sounds pretty confusing, but I have no better way of describing this).

Version-Release number of selected component (if applicable):
Public beta, 6.0.3

How reproducible:

Steps to Reproduce:
1. Connect Satellite 6 to RHEV 3.4 as compute resource. 
2. Create versioned template 'foo' in RHEV 3.4, with at least two versions. 
3. Try to use it in Satellite 6 by creating a new 'image' under the RHEV compute resource.

Actual results:
The 'image' selector field will show 'foo' and 'foo' for the two versions. Indistinguishable.

Expected results:
The 'image' selector field shows 'foo' and 'foo v.2 (enabled cloudinit)' or something similar.

Additional info:

Comment 1 Dominic Cleal 2014-07-10 14:24:19 UTC
Created redmine issue http://projects.theforeman.org/issues/6568 from this bug

Comment 3 Bryan Kearney 2015-02-18 23:03:38 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 4 Bryan Kearney 2015-03-25 08:02:26 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6568 has been closed
-------------
Tom Caspy
requires these pull requests to be merged and released in order for this to work:
https://github.com/abenari/rbovirt/pull/59
https://github.com/fog/fog/pull/3394
-------------
Tom Caspy
Applied in changeset commit:a647442376aceae2e539791790eb8f308b56cd3a.

Comment 11 Kedar Bidarkar 2016-04-19 11:04:12 UTC
Oh! ok, thanks for the info, will test it with rhev 3.5 then.

Comment 12 Kedar Bidarkar 2016-04-20 16:18:51 UTC
TESTED With sat62-snap8.1

We still face this issue with the above build.

Attaching a screenshot shortly.

Comment 13 Kedar Bidarkar 2016-04-20 16:23:48 UTC
Created attachment 1149124 [details]
versioned templates are indistinguishable

Comment 14 Bryan Kearney 2016-04-20 18:01:00 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 15 Bryan Kearney 2016-04-20 18:01:02 UTC
Upstream bug component is Compute Resources

Comment 17 Bryan Kearney 2016-04-26 14:01:11 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 21 Kedar Bidarkar 2016-07-07 14:57:43 UTC
It's been a while will verify this again with latest snap and update it here.

Comment 23 errata-xmlrpc 2016-07-27 08:42:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.