Bug 1118412 - Error when trying to update unverified email address
Summary: Error when trying to update unverified email address
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Authentication-Fedora
Version: unspecified
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 16:06 UTC by William Moreno
Modified: 2015-07-29 03:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 03:29:39 UTC


Attachments (Terms of Use)

Description William Moreno 2014-07-10 16:06:59 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
Build Identifier: 

I was trying  to sing in to the https://translate.zanata.org/ with FAS Account so I set the email the fedoraproject mail but I did not recive the activation email on my inbox, then I tried to use another mail accounto in Zanata to get the activation email  but I can not update the mail a get a error page.

Reproducible: Always

Steps to Reproduce:
1. Sing in Zanata with FAS and set the fedoroproget mail 
2. Try to update the email to get the activation email 
3.

Think than firts step must be ok, maybe a write a incorrect mail, but in step 2 I can set anothe mail :(
Actual Results:  
Get this error screen
http://imgur.com/vzGXJeA,vFr5zud
http://imgur.com/vzGXJeA,vFr5zud#1

Expected Results:  
Be able to update email to get the activation email

Comment 1 David Mason 2014-10-22 02:17:21 UTC
Notes from development team discussion

The error is generated because there is some error condition being generated when sending email, but our code is not handling it. We need to investigate this and change the code to properly handle the error condition and give a more informative error message.

Comment 2 Zanata Migrator 2015-07-29 03:29:39 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-294


Note You need to log in before you can comment on or make changes to this bug.