Bug 1118446 - wrong colour, instead of turquoise printing blue
Summary: wrong colour, instead of turquoise printing blue
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gutenprint
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 17:59 UTC by joerg.lechner
Modified: 2015-06-29 21:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:33:03 UTC


Attachments (Terms of Use)
/etc/cups/ppd/Canon-MP540-series.ppd after "turquoise print" (138.54 KB, application/vnd.cups-ppd)
2014-07-30 06:14 UTC, joerg.lechner
no flags Details
/etc/cups/ppd/Canon-MP540-series.ppd after the print with the test build (138.54 KB, application/vnd.cups-ppd)
2014-08-01 07:34 UTC, joerg.lechner
no flags Details
print of turquoise colour via gutenprint-cups-5.2.9-16.fc20 and via firefox (264.53 KB, image/jpeg)
2014-08-01 12:02 UTC, joerg.lechner
no flags Details
Tourquoise Colour prints Gimp on F21 Final TC4 and Win 8.1 (76.90 KB, image/jpeg)
2014-11-26 08:02 UTC, joerg.lechner
no flags Details

Description joerg.lechner 2014-07-10 17:59:21 UTC
Description of problem:
Printing a colour photo with a Canon Pixma MP540 showed loss of Yellow colour compared to the screen and to a printout of the same photo with Windows XP, i.e turquoise appeared as blue. System used F20, LXDE desktop, gutenprint-cups 5.2.9-14.fc20, printer setting cmyk colour.

Version-Release number of selected component (if applicable):
gutenprint-cups 5.2.9-14.fc20

How reproducible:
printing again the same photo

Steps to Reproduce:
1.print a photo containing also turquoise colour
2.
3.

Actual results:
turquoise printed as blue

Expected results:
turquoise printed as turquoise

Additional info:

Comment 1 Tim Waugh 2014-07-25 12:14:55 UTC
Does a test page show correct colours?

Also, what output do you get from this command?:
sudo escputil --new -ink-level --raw-device /dev/usb/lp0

Comment 2 joerg.lechner 2014-07-27 19:59:36 UTC
The test page seem to show correct colours. But it is hard or nearly impossible to identify turquoise on the test page.

The command "escputil --new -ink-level --raw-device /dev/usb/lp0" seem to be for Epson printers - I have a Canon.

Wether the command "escputil --new -ink-level --raw-device /dev/usb/lp0"
nor "escputil -ink-level --raw-device /dev/usb/lp0" did work. Possibly an Epson Stylus is expected.

I used Copy - Paste, did I use this command in a wrong way?

I tested now to print turquoise from the following page 
"http://home.arcor.de/pierrezimmer/bilder/herbol/farbwahlwand/tuerkis1.jpg"

Printing with firefox showed the correct turquoise colours.

But printing with GIMP, where I have chosen "print with Gutenprint" showed blue instead of turquoise - The foto where I wondered about turquoise resulting in blue colour, I printed also using GIMP.

Is this a GIMP problem? Not a Gutenprint-Cups?

Comment 3 Tim Waugh 2014-07-28 10:41:30 UTC
Sorry, the escputil is for Epson printers, yes.

When you print using 'Print with Gutenprint', please look at the 'Output' tab and click 'Adjust Output...'. Have you previously adjusted any of these settings? Are they as they should be? If you aren't sure, please click 'Set Defaults', close that window, and try printing again.

Another thing to try is to download tuerkis1.jpg and print it from the command line: lp -d thequeue tuerkis1.jpg (replace 'thequeue' with your print queue name).

What results do you get from the above tests?

Comment 4 joerg.lechner 2014-07-28 16:38:53 UTC
I did the 2 tests You proposed. Both resulting in blue colour, expected was turquoise colour.

First test:
GIMP - print with gutenprint

Printer Settings:
Canon PIXMA MP540
Media Type:   Plain Paper
Media Source: Cassette
Resolution:   600x600 DPI
Ink Type:     CMYK Color
Ink Set:      None
Print Quality: Standard

Output Type:  Color

There is no further 'Adjust Output' button

Second Test:
[root@localhost joerg]# lp -d Canon-MP540-series /home/joerg/Pictures/turquoise.png
request id is Canon-MP540-series-155 (1 file(s))
[root@localhost joerg]# 

Printing itself was in both cases ok, but I got in both cases the wrong colour.
I used the admin account (su), which I do sometimes, when I don't know, if a test will run on the normal user level.

Comment 5 Tim Waugh 2014-07-29 12:27:50 UTC
Please attach /etc/cups/ppd/Canon-MP540-series.ppd using the 'Add an attachment' link above. Thanks.

Comment 6 joerg.lechner 2014-07-30 06:14:13 UTC
Created attachment 922430 [details]
/etc/cups/ppd/Canon-MP540-series.ppd after "turquoise print"

according to needinfo

Comment 7 Tim Waugh 2014-07-30 09:18:27 UTC
I've asked about this upstream:
  http://sourceforge.net/p/gimp-print/mailman/message/32663922/

Comment 8 Tim Waugh 2014-07-31 16:42:14 UTC
Here's a test build with a change from upstream:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=7219081

Are you able to try that out?

Comment 9 joerg.lechner 2014-08-01 07:34:30 UTC
Created attachment 923116 [details]
/etc/cups/ppd/Canon-MP540-series.ppd after the print with the test build

ppd file after print trial of printing turquoise colour after installing the build of gutenprint

Comment 10 joerg.lechner 2014-08-01 07:40:19 UTC
I have downloaded and then installed the following, see installation protocol. The result in a print trial of turquoise is blue colours not so dark as before installing the test build, but in no way turquoise colour, which I wanted.

[joerg@localhost ~]$ su
Password: 
[root@localhost joerg]# yum install /home/joerg/Downloads/gutenprint*.rpm
Loaded plugins: langpacks
Examining /home/joerg/Downloads/gutenprint-5.2.9-16.fc20.i686.rpm: gutenprint-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-5.2.9-16.fc20.i686.rpm as an update to gutenprint-5.2.9-14.fc20.i686
Examining /home/joerg/Downloads/gutenprint-cups-5.2.9-16.fc20.i686.rpm: gutenprint-cups-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-cups-5.2.9-16.fc20.i686.rpm as an update to gutenprint-cups-5.2.9-14.fc20.i686
Examining /home/joerg/Downloads/gutenprint-debuginfo-5.2.9-16.fc20.i686.rpm: gutenprint-debuginfo-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-debuginfo-5.2.9-16.fc20.i686.rpm to be installed
Examining /home/joerg/Downloads/gutenprint-devel-5.2.9-16.fc20.i686.rpm: gutenprint-devel-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-devel-5.2.9-16.fc20.i686.rpm to be installed
Examining /home/joerg/Downloads/gutenprint-doc-5.2.9-16.fc20.i686.rpm: gutenprint-doc-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-doc-5.2.9-16.fc20.i686.rpm to be installed
Examining /home/joerg/Downloads/gutenprint-extras-5.2.9-16.fc20.i686(1).rpm: gutenprint-extras-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-extras-5.2.9-16.fc20.i686(1).rpm to be installed
Examining /home/joerg/Downloads/gutenprint-extras-5.2.9-16.fc20.i686.rpm: gutenprint-extras-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-extras-5.2.9-16.fc20.i686.rpm to be installed
Examining /home/joerg/Downloads/gutenprint-foomatic-5.2.9-16.fc20.i686(1).rpm: gutenprint-foomatic-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-foomatic-5.2.9-16.fc20.i686(1).rpm to be installed
Examining /home/joerg/Downloads/gutenprint-foomatic-5.2.9-16.fc20.i686.rpm: gutenprint-foomatic-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-foomatic-5.2.9-16.fc20.i686.rpm to be installed
Examining /home/joerg/Downloads/gutenprint-plugin-5.2.9-16.fc20.i686(1).rpm: gutenprint-plugin-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-plugin-5.2.9-16.fc20.i686(1).rpm as an update to gutenprint-plugin-5.2.9-14.fc20.i686
Examining /home/joerg/Downloads/gutenprint-plugin-5.2.9-16.fc20.i686.rpm: gutenprint-plugin-5.2.9-16.fc20.i686
Marking /home/joerg/Downloads/gutenprint-plugin-5.2.9-16.fc20.i686.rpm as an update to gutenprint-plugin-5.2.9-14.fc20.i686
Resolving Dependencies
--> Running transaction check
---> Package gutenprint.i686 0:5.2.9-14.fc20 will be updated
---> Package gutenprint.i686 0:5.2.9-16.fc20 will be an update
---> Package gutenprint-cups.i686 0:5.2.9-14.fc20 will be updated
---> Package gutenprint-cups.i686 0:5.2.9-16.fc20 will be an update
---> Package gutenprint-debuginfo.i686 0:5.2.9-16.fc20 will be installed
---> Package gutenprint-devel.i686 0:5.2.9-16.fc20 will be installed
--> Processing Dependency: gtk2-devel for package: gutenprint-devel-5.2.9-16.fc20.i686
--> Processing Dependency: pkgconfig(gtk+-2.0) for package: gutenprint-devel-5.2.9-16.fc20.i686
---> Package gutenprint-doc.i686 0:5.2.9-16.fc20 will be installed
---> Package gutenprint-extras.i686 0:5.2.9-16.fc20 will be installed
---> Package gutenprint-foomatic.i686 0:5.2.9-16.fc20 will be installed
--> Processing Dependency: foomatic for package: gutenprint-foomatic-5.2.9-16.fc20.i686
--> Processing Dependency: foomatic-db for package: gutenprint-foomatic-5.2.9-16.fc20.i686
---> Package gutenprint-plugin.i686 0:5.2.9-14.fc20 will be updated
---> Package gutenprint-plugin.i686 0:5.2.9-16.fc20 will be an update
--> Running transaction check
---> Package foomatic.i686 0:4.0.9-6.fc20 will be installed
---> Package foomatic-db.noarch 0:4.0-39.20130604.fc20 will be installed
--> Processing Dependency: foomatic-db-ppds = 4.0-39.20130604.fc20 for package: foomatic-db-4.0-39.20130604.fc20.noarch
--> Processing Dependency: foomatic-db-filesystem = 4.0-39.20130604.fc20 for package: foomatic-db-4.0-39.20130604.fc20.noarch
---> Package gtk2-devel.i686 0:2.24.22-2.fc20 will be installed
--> Processing Dependency: pango-devel >= 1.20.0-1 for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: glib2-devel >= 2.28.0-1 for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: cairo-devel >= 1.6.0-1 for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: atk-devel >= 1.29.4-2 for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(pangoft2) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(pangocairo) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(pango) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(gio-2.0) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(gdk-pixbuf-2.0) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(cairo) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: pkgconfig(atk) for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: libpng-devel for package: gtk2-devel-2.24.22-2.fc20.i686
--> Processing Dependency: gdk-pixbuf2-devel for package: gtk2-devel-2.24.22-2.fc20.i686
--> Running transaction check
---> Package atk-devel.i686 0:2.10.0-1.fc20 will be installed
---> Package cairo-devel.i686 0:1.13.1-0.1.git337ab1f.fc20 will be installed
--> Processing Dependency: pkgconfig(pixman-1) >= 0.30.0 for package: cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686
--> Processing Dependency: pixman-devel >= 0.18.4 for package: cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686
--> Processing Dependency: pkgconfig(egl) for package: cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686
---> Package foomatic-db-filesystem.noarch 0:4.0-39.20130604.fc20 will be installed
---> Package foomatic-db-ppds.noarch 0:4.0-39.20130604.fc20 will be installed
---> Package gdk-pixbuf2-devel.i686 0:2.30.3-1.fc20 will be installed
---> Package glib2-devel.i686 0:2.38.2-2.fc20 will be installed
---> Package libpng-devel.i686 2:1.6.6-3.fc20 will be installed
---> Package pango-devel.i686 0:1.36.1-3.fc20 will be installed
--> Processing Dependency: pkgconfig(harfbuzz) for package: pango-devel-1.36.1-3.fc20.i686
--> Running transaction check
---> Package harfbuzz-devel.i686 0:0.9.27-1.fc20 will be installed
--> Processing Dependency: pkgconfig(icu-uc) for package: harfbuzz-devel-0.9.27-1.fc20.i686
---> Package mesa-libEGL-devel.i686 0:10.1.5-1.20140607.fc20 will be installed
---> Package pixman-devel.i686 0:0.30.0-3.fc20 will be installed
--> Running transaction check
---> Package libicu-devel.i686 0:50.1.2-10.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch   Version                    Repository       Size
================================================================================
Installing:
 gutenprint-debuginfo   i686   5.2.9-16.fc20              /gutenprint-debuginfo-5.2.9-16.fc20.i686
                                                                          6.3 M
 gutenprint-devel       i686   5.2.9-16.fc20              /gutenprint-devel-5.2.9-16.fc20.i686
                                                                          4.8 M
 gutenprint-doc         i686   5.2.9-16.fc20              /gutenprint-doc-5.2.9-16.fc20.i686
                                                                          832 k
 gutenprint-extras      i686   5.2.9-16.fc20              /gutenprint-extras-5.2.9-16.fc20.i686(1)
                                                                          695 k
 gutenprint-foomatic    i686   5.2.9-16.fc20              /gutenprint-foomatic-5.2.9-16.fc20.i686(1)
                                                                          120 M
Updating:
 gutenprint             i686   5.2.9-16.fc20              /gutenprint-5.2.9-16.fc20.i686
                                                                           19 M
 gutenprint-cups        i686   5.2.9-16.fc20              /gutenprint-cups-5.2.9-16.fc20.i686
                                                                          555 k
 gutenprint-plugin      i686   5.2.9-16.fc20              /gutenprint-plugin-5.2.9-16.fc20.i686(1)
                                                                           19 k
Installing for dependencies:
 atk-devel              i686   2.10.0-1.fc20              fedora          158 k
 cairo-devel            i686   1.13.1-0.1.git337ab1f.fc20 fedora          297 k
 foomatic               i686   4.0.9-6.fc20               fedora          246 k
 foomatic-db            noarch 4.0-39.20130604.fc20       fedora          1.0 M
 foomatic-db-filesystem noarch 4.0-39.20130604.fc20       fedora          9.1 k
 foomatic-db-ppds       noarch 4.0-39.20130604.fc20       fedora           27 M
 gdk-pixbuf2-devel      i686   2.30.3-1.fc20              updates         209 k
 glib2-devel            i686   2.38.2-2.fc20              fedora          412 k
 gtk2-devel             i686   2.24.22-2.fc20             fedora          2.9 M
 harfbuzz-devel         i686   0.9.27-1.fc20              updates         101 k
 libicu-devel           i686   50.1.2-10.fc20             fedora          702 k
 libpng-devel           i686   2:1.6.6-3.fc20             updates         162 k
 mesa-libEGL-devel      i686   10.1.5-1.20140607.fc20     updates          28 k
 pango-devel            i686   1.36.1-3.fc20              updates         315 k
 pixman-devel           i686   0.30.0-3.fc20              fedora           20 k

Transaction Summary
================================================================================
Install  5 Packages (+15 Dependent packages)
Upgrade  3 Packages

Total size: 186 M
Total download size: 34 M
Is this ok [y/d/N]: y
Downloading packages:
(1/15): atk-devel-2.10.0-1.fc20.i686.rpm                    | 158 kB  00:02     
(2/15): cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686.rpm     | 297 kB  00:00     
(3/15): foomatic-4.0.9-6.fc20.i686.rpm                      | 246 kB  00:00     
(4/15): foomatic-db-4.0-39.20130604.fc20.noarch.rpm         | 1.0 MB  00:00     
(5/15): foomatic-db-filesystem-4.0-39.20130604.fc20.noarch. | 9.1 kB  00:00     
(6/15): glib2-devel-2.38.2-2.fc20.i686.rpm                  | 412 kB  00:00     
(7/15): gtk2-devel-2.24.22-2.fc20.i686.rpm                  | 2.9 MB  00:01     
(8/15): gdk-pixbuf2-devel-2.30.3-1.fc20.i686.rpm            | 209 kB  00:01     
(9/15): harfbuzz-devel-0.9.27-1.fc20.i686.rpm               | 101 kB  00:01     
(10/15): libicu-devel-50.1.2-10.fc20.i686.rpm               | 702 kB  00:00     
(11/15): libpng-devel-1.6.6-3.fc20.i686.rpm                 | 162 kB  00:00     
(12/15): mesa-libEGL-devel-10.1.5-1.20140607.fc20.i686.rpm  |  28 kB  00:00     
(13/15): pango-devel-1.36.1-3.fc20.i686.rpm                 | 315 kB  00:00     
(14/15): pixman-devel-0.30.0-3.fc20.i686.rpm                |  20 kB  00:00     
(15/15): foomatic-db-ppds-4.0-39.20130604.fc20.noarch.rpm   |  27 MB  00:06     
--------------------------------------------------------------------------------
Total                                              3.2 MB/s |  34 MB  00:10     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Updating   : gutenprint-5.2.9-16.fc20.i686                               1/26 
  Installing : glib2-devel-2.38.2-2.fc20.i686                              2/26 
  Installing : 2:libpng-devel-1.6.6-3.fc20.i686                            3/26 
  Installing : foomatic-db-filesystem-4.0-39.20130604.fc20.noarch          4/26 
  Installing : foomatic-db-ppds-4.0-39.20130604.fc20.noarch                5/26 
  Installing : foomatic-db-4.0-39.20130604.fc20.noarch                     6/26 
  Installing : atk-devel-2.10.0-1.fc20.i686                                7/26 
  Installing : mesa-libEGL-devel-10.1.5-1.20140607.fc20.i686               8/26 
  Installing : pixman-devel-0.30.0-3.fc20.i686                             9/26 
  Installing : cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686                10/26 
  Installing : foomatic-4.0.9-6.fc20.i686                                 11/26 
  Installing : gdk-pixbuf2-devel-2.30.3-1.fc20.i686                       12/26 
  Installing : libicu-devel-50.1.2-10.fc20.i686                           13/26 
  Installing : gutenprint-foomatic-5.2.9-16.fc20.i686                     14/26 
  Installing : gutenprint-doc-5.2.9-16.fc20.i686                          15/26 
  Installing : gutenprint-debuginfo-5.2.9-16.fc20.i686                    16/26 
  Installing : harfbuzz-devel-0.9.27-1.fc20.i686                          17/26 
  Installing : pango-devel-1.36.1-3.fc20.i686                             18/26 
  Installing : gtk2-devel-2.24.22-2.fc20.i686                             19/26 
  Installing : gutenprint-devel-5.2.9-16.fc20.i686                        20/26 
  Installing : gutenprint-extras-5.2.9-16.fc20.i686                       21/26 
  Updating   : gutenprint-cups-5.2.9-16.fc20.i686                         22/26 
  Updating   : gutenprint-plugin-5.2.9-16.fc20.i686                       23/26 
  Cleanup    : gutenprint-plugin-5.2.9-14.fc20.i686                       24/26 
  Cleanup    : gutenprint-cups-5.2.9-14.fc20.i686                         25/26 
  Cleanup    : gutenprint-5.2.9-14.fc20.i686                              26/26 
  Verifying  : libicu-devel-50.1.2-10.fc20.i686                            1/26 
  Verifying  : gutenprint-devel-5.2.9-16.fc20.i686                         2/26 
  Verifying  : 2:libpng-devel-1.6.6-3.fc20.i686                            3/26 
  Verifying  : pixman-devel-0.30.0-3.fc20.i686                             4/26 
  Verifying  : foomatic-4.0.9-6.fc20.i686                                  5/26 
  Verifying  : glib2-devel-2.38.2-2.fc20.i686                              6/26 
  Verifying  : gutenprint-extras-5.2.9-16.fc20.i686                        7/26 
  Verifying  : mesa-libEGL-devel-10.1.5-1.20140607.fc20.i686               8/26 
  Verifying  : gutenprint-cups-5.2.9-16.fc20.i686                          9/26 
  Verifying  : foomatic-db-filesystem-4.0-39.20130604.fc20.noarch         10/26 
  Verifying  : gutenprint-5.2.9-16.fc20.i686                              11/26 
  Verifying  : gutenprint-debuginfo-5.2.9-16.fc20.i686                    12/26 
  Verifying  : foomatic-db-ppds-4.0-39.20130604.fc20.noarch               13/26 
  Verifying  : cairo-devel-1.13.1-0.1.git337ab1f.fc20.i686                14/26 
  Verifying  : gdk-pixbuf2-devel-2.30.3-1.fc20.i686                       15/26 
  Verifying  : pango-devel-1.36.1-3.fc20.i686                             16/26 
  Verifying  : gtk2-devel-2.24.22-2.fc20.i686                             17/26 
  Verifying  : foomatic-db-4.0-39.20130604.fc20.noarch                    18/26 
  Verifying  : gutenprint-foomatic-5.2.9-16.fc20.i686                     19/26 
  Verifying  : gutenprint-doc-5.2.9-16.fc20.i686                          20/26 
  Verifying  : harfbuzz-devel-0.9.27-1.fc20.i686                          21/26 
  Verifying  : atk-devel-2.10.0-1.fc20.i686                               22/26 
  Verifying  : gutenprint-plugin-5.2.9-16.fc20.i686                       23/26 
  Verifying  : gutenprint-5.2.9-14.fc20.i686                              24/26 
  Verifying  : gutenprint-plugin-5.2.9-14.fc20.i686                       25/26 
  Verifying  : gutenprint-cups-5.2.9-14.fc20.i686                         26/26 

Installed:
  gutenprint-debuginfo.i686 0:5.2.9-16.fc20                                     
  gutenprint-devel.i686 0:5.2.9-16.fc20                                         
  gutenprint-doc.i686 0:5.2.9-16.fc20                                           
  gutenprint-extras.i686 0:5.2.9-16.fc20                                        
  gutenprint-foomatic.i686 0:5.2.9-16.fc20                                      

Dependency Installed:
  atk-devel.i686 0:2.10.0-1.fc20                                                
  cairo-devel.i686 0:1.13.1-0.1.git337ab1f.fc20                                 
  foomatic.i686 0:4.0.9-6.fc20                                                  
  foomatic-db.noarch 0:4.0-39.20130604.fc20                                     
  foomatic-db-filesystem.noarch 0:4.0-39.20130604.fc20                          
  foomatic-db-ppds.noarch 0:4.0-39.20130604.fc20                                
  gdk-pixbuf2-devel.i686 0:2.30.3-1.fc20                                        
  glib2-devel.i686 0:2.38.2-2.fc20                                              
  gtk2-devel.i686 0:2.24.22-2.fc20                                              
  harfbuzz-devel.i686 0:0.9.27-1.fc20                                           
  libicu-devel.i686 0:50.1.2-10.fc20                                            
  libpng-devel.i686 2:1.6.6-3.fc20                                              
  mesa-libEGL-devel.i686 0:10.1.5-1.20140607.fc20                               
  pango-devel.i686 0:1.36.1-3.fc20                                              
  pixman-devel.i686 0:0.30.0-3.fc20                                             

Updated:
  gutenprint.i686 0:5.2.9-16.fc20         gutenprint-cups.i686 0:5.2.9-16.fc20 
  gutenprint-plugin.i686 0:5.2.9-16.fc20 

Complete!
[root@localhost jo

Comment 11 joerg.lechner 2014-08-01 12:02:23 UTC
Created attachment 923270 [details]
print of turquoise colour via gutenprint-cups-5.2.9-16.fc20 and via firefox

in the attachement I show an example printout of an example of a turquoise colour with GIMP, "print with gutenprint" branch. And an example of the same turquoise colour printed with firefox. Both printouts in the same software environment, but I don't know, which printer driver uses firefox, I only chose in GIMP and in Firefox the Canon Pixma MP540 printer.

Comment 12 joerg.lechner 2014-10-04 15:22:45 UTC
I tried to print "blue colours" (Cyan, Turquoise etc) with F21 Beta TC1 using Libre Office Writer. All Cyan and Turquoise is printed in more or less dark blue. Printer is the same - Canon Pixma MP540.

Comment 13 Chris Murphy 2014-11-24 18:32:07 UTC
(In reply to joerg.lechner from comment #11)
The print from Firefox and GIMP seems to demonstrate printing the source color (P2.20.73) correctly is possible; and assuming the user print settings were identical in the two applications, it suggests one or more bugs (just because FireFox produces the intended color doesn't mean it's bug free, there can be counteracting bugs).

Is there a way to intercept and get access to the (pdf?) spool files from both applications? I'd like to see what the objects RGB values and /ICCBased color space are from the two applications.

Comment 14 joerg.lechner 2014-11-25 06:33:48 UTC
I am sure that it's possible to supply the requested data. My problem is that, I need a more detailed "how to". I am not so firm in the file structures etc. My tests are tests of a user not expert.
Currently I have a fresh install of F21 Final TC4 for testing purposes only.
How shall I intercept? Where can I find the spool files?
gutenprint 5.2.10-5.fc21 x86_64
kernel 3.17.4-300.fc21 x86_64
firefox 33.1-2.fc21 x86_64
gimp 2.8.14-1.fc21 x86_64

Comment 15 Tim Waugh 2014-11-25 12:04:04 UTC
This page has information on diagnosing problems including running filters by hand etc:
https://fedoraproject.org/wiki/How_to_debug_printing_problems

Comment 16 joerg.lechner 2014-11-26 08:02:50 UTC
Created attachment 961524 [details]
Tourquoise Colour prints Gimp on F21 Final TC4 and Win 8.1

There are 3 prints of Tourquoise colours
A) Gimp, "print with Gutenprint" button
B) Gimp, "print" button
C) Windows 8.1, program Irfanview

F21 SW versions as told in comment 14.
Before going on further, I have to study the "How To" of comment 15. I can say the printer driver (or something else) used by Gimp clicking on the print button (B) seem to be ok. The printer driver (or something else) used by clicking on the button "print with Gutenprint" (A) doesn't mix Yellow colour, to that, what should be Tourquoise, therefore this printout is something like blue.
All printer drivers were set to CMYK colours. All printouts are on glossy foto paper. Further on I didn't have daylight while taking the fotos.

Comment 17 joerg.lechner 2014-11-27 03:27:48 UTC
Tried in addition other programs:
Firefox printing with CMYK    Turquoise print ok
Firefox printing with RGB     Turquoise is printed blue nok

Shotwell result is the same as Firefox: Print with CMYK ok, RGB nok

Libre Office Draw: "print from driver" or "print color" both print Turquoise as Blue nok

Comment 18 joerg.lechner 2014-11-28 06:17:36 UTC
I have done now a driver check. Normally at installation time the cups driver "simplified" is used. In this driver You can not make a colour adjustment. I tried the driver: "Canon MP540 series - CUPS+Gutenprint v5.2.10" (not the simplified one). There is a menue "print options" (in my case German "Druckeroptionen"). Most data in the menue are not prepopulated. I took i.e. for Cyan 1000, Magenta 1000 and Yellow 2000, the print in Gimp with "print with Gutenberg" was better. But only a printer colour expert can populate these data. I think the error is, that these data are not prepopulated and in the installation the wrong driver version (the simplified one) is advised.

I did only a test with Gimp, but I think for the other applications it will be the same.

Comment 19 joerg.lechner 2014-11-30 20:31:17 UTC
Hi Tim,
is it possible to get again a testbuild like You did in Comment 7/8? I don't know, if I did the test in F20 with Canon MP540 series - CUPS+Gutenprint v5.2.10" (not the simplified one) or with the simplified one.
I would like to try this again with the "not simplified" one and try to set some different percentages of colour combinations and then print turquiose colours, changing the colour combinations percentage is not possible with the "simplified" driver version.
Thank You in advance.

Comment 20 joerg.lechner 2014-11-30 20:38:30 UTC
Sorry I didn't say, testbuild for F21 (currently Final RC1). Otherwise I would have to install again F20 (is also possible, if I can't get a testbuild for F21).

Comment 21 joerg.lechner 2014-12-04 08:12:25 UTC
I tried again Fedora 20 (according to comment 7 and comment 8. Also tested with F21 Final RC5. All Turquoise is still printed Blue

Comment 22 joerg.lechner 2014-12-07 07:14:12 UTC
I deinstalled all, what is named Gutenprint and tried to print with Gimp via the menue "print" (not "print with Gutenprint"). Printing was not possible. Does anyone know, which printer driver -especially color settings- is used printing with the Gimp "print" command?
Reason: Printing with the Gimp "print" command, Gutenprint installed, gives turquoise colors very much better, then printing with Gimp "print with Gutenprint", which doesn't give turquoise colors.
My system is as it was, when I started filing this bug (printer Canon Pixma MP540, OS Fedora, currently F21 Final RC5).

Comment 23 joerg.lechner 2014-12-07 13:27:51 UTC
I wanted to write an attachment with the ppd file of the "successful" print of turquoise colour with the Gimp menue "print", but I could'nt make this attachment, possibly my fault. The Gimp menue "print with Gutenprint" still doesn't print any variation/mixture of the colour blue(with Yellow or Green).
For me this result is sufficient. I use the Gimp menue "print" and not "print with gutenprint". Via deleting and inserting the ppd file again, I got the impression that both print menues in Gimp use the same ppd file.
Is this a Gimp error? Or a Gutenprint error?
I have saved the ppd file, if anyone is interested in.

Comment 24 Chris Murphy 2014-12-07 19:27:42 UTC
Possibly if you post to the openicc list someone might have advice on how to further test this to isolate the problem. I don't expect much in the way of response in a non-upstream bug report because there are too many pieces involved and a specific bug hasn't been identified. I'm not convinced whether this is a gutenprint bug.
http://lists.freedesktop.org/mailman/listinfo/openicc

Comment 25 joerg.lechner 2014-12-10 07:29:54 UTC
Faulty file localized.
gutenprint-plugin 5.2.10-5.fc21 x86_64

Tested the following:
-Installation of F21 Final.
-Installation of nearly all "Gimp files", all what seems to contribute to Gimp working, except gutenprint-plugin.
-Starting Gimp, there was only the menue button "print", no "print with gutenprint"
-printed on glossy fotopaper a turquoise colour scheme. Colours ok.
-installed file gutenprint-plugin
-started again Gimp
-now there is the menue button "print with gutenprint"
-print with this button -> colours faulty 

Used Driver in both tests: stp-bjc-MP540-series.5.2.sim.ppd

Comment 26 joerg.lechner 2014-12-13 07:47:46 UTC
I have an additional question:
What should "gutenprint-plugin" make better in Gimp? Currently "gutenprint-plugin" -at least for some Canon printers- can be omitted, it's useless. As I have seen the "Gimp option" "print" uses the same driver as the "Gimp Option" "print with gutenprint" (when gutenprint-plugin is installed), but "gutenprint-plugin" in the Gimp Option "print with gutenprint" doesn't work ok.

Is there any use of "Gutenprint-Plugin" in Fedora 21?

Comment 27 joerg.lechner 2015-04-26 09:50:29 UTC
Just tested Fedora 22 Beta 3 (Beta Release).
It is still not possible to print turquoise copours with the Canon Pixma MP540.

But F21 Final does print turquoise colours with Gimp !

I hope that F22 Final will print turquoise colours as F21 does.

Comment 28 joerg.lechner 2015-05-14 03:03:40 UTC
Now F22 is short to freeze for Final (F22 TC3). Tested printing Turquoise colours with Libre Office via Canon Pixma MP540. Turquoise is still printed as Blue. Here F22 is worse than F21. I fear, I have to use for Foto printouts or else Grafic work still F21 instead of F22.

Comment 29 Chris Murphy 2015-05-14 04:19:11 UTC
It's rather unlikely gutenprint is to blame because it's the least changed item in the printing pipeline release to release. CUPS maybe, but it doesn't directly have anything to do with color space conversions. More plausible is some sort of change in either the application, how it submits data, or ghostscript although its RGB source/destination space assumptions were changed a while ago, I think before Fedora 21. Anyway, it's tedious and annoying to troubleshoot, but it's going to need to be finer granularity than turquoise prints blue.

If the turquoise is specified CMYK, I'd have every reason to suspect it's going to get converted somewhere to RGB in the pipeline because pretty much all consumer printers these days want RGB data. So either the application, ghostscript will do that. I know the gutenprint printer PPD should say what space the printer wants, I'm not totally sure how CUPS decides what to do based on this if it somehow gets ghostscript to do that conversion. But what you're describing turquoise to blue, is hue torquing, it's quite common when either the assumed source space or destination space are wrong and a conversion (from source to destination) is happening.

If the turquoise is RGB, then that suggests an RGB-RGB' conversion. This sort of thing doesn't ever happen by default on Windows, but can happen on OS X, I don't know whether or how it'd happen on Fedora. But I'm willing to bet dollars to donuts you can get the same version of gutenprint on Fedora 21 and 22 - either the 22 version on 21, or the 21 version on 22, and in that way isolate whether or not it is in fact gutenprint related. If not, then it's app vs CUPS vs ghostscript to isolate next.

Comment 30 joerg.lechner 2015-05-14 11:30:23 UTC
You are right, I think it's my error.
Program tested GIMP, print button: "print" (not "print with Gutenprint" !)
cups 2.02-5.fc22-x86_64

Printer settings:
1) Extended- Printer Features Common:
     Ink Type CMYK Color (no RGB setting possible)

2) Color
   Color Model: RGB Color   -> test result: turquoise printed blue
                CMYK        -> test result: turquoise printed turquoise

Thank You for Your help in understanding color printing!

Comment 31 Chris Murphy 2015-05-14 16:19:15 UTC
Hue torquing doesn't happen when printing with Color Model set to CMYK, but does happen when it's set to RGB. That's unexpected. It suggests one of two things:

- RGB source and destination are the same, there is a null transform in the print pipeline, and the torquing is happening within the gutenprint driver. This is unlikely because:
gutenprint-5.2.10-7.fc21
gutenprint-5.2.10-10.fc22
I'm not sure if the difference between these, but I seriously doubt that any lookup tables in the print driver have changed, it's probably minor packaging differences since the gutenprint versions are actually identical.

- RGB source and destination are different, and a transform is happening in the print pipeline before getting to the gutenprint driver. This is plausible because:
cups-1.7.5-16.fc21
cups-2.0.2-5.fc22

That's a fairly significant change, and I vaguely recall color management related changes between 1.7 and 2.0.

ghostscript-9.15-6.fc21
ghostscript-9.16-2.fc22

Seems minor, but there's a large pile of changes between these versions. http://www.ghostscript.com/doc/9.16/History9.htm
Since there's no incompatible changes, it might be worth going to Fedora 21, and seeing if you can install ghostscript-9.16-2.fc22 only, and print again to see if that changes things or not. Only then is it really worth going through that changelog to find out what might explain it.

Comment 32 joerg.lechner 2015-05-15 08:37:49 UTC
Have now tested fc21 the same way as fc22 (Ghostscript 9.15-6.fc21, Cups 1.7.5-15.fc21, Gutenprint 5.2.10-5.fc21, all x86_64). My information so far was incomplete. The test result with fc21 is the same as with fc22.

Printer Canon Pixma MP540:
Color Model CMYK
Ink Type    CMYK   Test Result  Turquoise -> printed as Turquoise

Color Model RGB Color
Ink Type    CMYK   Test Result  Turquoise -> printed as Blue

Sorry for this. If this (RGB versus CMYK) is an Ghostscript error I can do further tests, when You tell me, how and what to test. I have 2 testsystems, one external disk fc21, the other external disk fc22.

Comment 33 Fedora End Of Life 2015-05-29 12:20:41 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 34 Fedora End Of Life 2015-06-29 21:33:03 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.