Bug 1118448 - Screen Freezes for 1 second every 5 seconds
Summary: Screen Freezes for 1 second every 5 seconds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 18:04 UTC by Dan Sneddon
Modified: 2015-01-20 00:15 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-17 04:58:00 UTC


Attachments (Terms of Use)
boot log from affected system (11.95 KB, text/x-log)
2014-07-10 18:04 UTC, Dan Sneddon
no flags Details
journalctl output from latest boot (drm.debug=6) (181.25 KB, text/x-log)
2014-07-10 19:53 UTC, Dan Sneddon
no flags Details
Xorg log from latest boot and X startup (40.62 KB, text/x-log)
2014-07-10 19:55 UTC, Dan Sneddon
no flags Details
dmesg with drm.debug=6 (242.42 KB, text/x-log)
2014-07-11 18:06 UTC, Dan Sneddon
no flags Details
Additional dmesg with more time run with lid closed (245.97 KB, text/x-log)
2014-07-11 18:10 UTC, Dan Sneddon
no flags Details
dmesg w/drm.debug=6 and kernel-3.17.0-0.rc2.git0.1.fc22.x86_64 (251.83 KB, text/plain)
2014-08-27 01:02 UTC, Brent Baude
no flags Details

Description Dan Sneddon 2014-07-10 18:04:19 UTC
Created attachment 917156 [details]
boot log from affected system

Description of problem:
On certain Lenovo laptops (tested on multiple T540p laptops), the screen will freeze for 1 second every 5 seconds (4 seconds normal, 1 second frozen, repeat). This only happens when an external monitor is attached, and it is the only display (the laptop lid is closed or the built-in display is disabled through the use of the <Fn-F7> monitor selection button. When both the internal and external monitors are enabled it does not happen. There are no CPU spikes and audio is not affected.

I tried disabling all Gnome extensions, and the problem still occurs.


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.21.15-7.fc20.x86_64


How reproducible:
Happens every time


Steps to Reproduce:
1. Attach external monitor to mini-DisplayPort
2. Close lid or disable internal screen
3.

Actual results:
Screen freezes for 1 second every 5 seconds. Can easily be seen while playing a video.


Expected results:
Screen works without freezing


Additional info:

Comment 1 Dan Sneddon 2014-07-10 19:53:57 UTC
Created attachment 917171 [details]
journalctl output from latest boot (drm.debug=6)

Comment 2 Dan Sneddon 2014-07-10 19:55:05 UTC
Created attachment 917172 [details]
Xorg log from latest boot and X startup

I closed and opened the lid several times. This bug is triggered when I close the lid (disabling the internal monitor on my laptop)

Comment 4 Dave Airlie 2014-07-11 01:15:17 UTC
I really need a dmesg with drm.debug=6, not journalctl output at least the one here doesn't contain any events 4s apart which I can see.

Comment 5 James Rankin 2014-07-11 14:18:50 UTC
I too am experiencing this issue on a t540p. I've noticed that the issue is far less impactful (or perhaps entirely gone) when using kernel 3.13.10-200.fc20.x86_64.

Comment 6 Dan Sneddon 2014-07-11 18:06:56 UTC
Created attachment 917408 [details]
dmesg with drm.debug=6

Comment 7 Dan Sneddon 2014-07-11 18:10:57 UTC
Created attachment 917410 [details]
Additional dmesg with more time run with lid closed

Comment 8 Dan Sneddon 2014-07-11 18:16:34 UTC
Note that if I open the lid on the laptop, the periodic messages to dmesg stop. In fact, almost nothing else gets logged. If I close the lid, I get the hotplug and other messages repeatedly.

Comment 9 Dan Sneddon 2014-07-12 01:53:05 UTC
I am running kernel 3.14.9-200.fc20.x86_64, FWIW

Comment 10 Dave Airlie 2014-07-16 07:37:18 UTC
is this happening with the 3.15 kernels as well for anyone?

Comment 11 Dave Airlie 2014-07-16 07:42:33 UTC
also what models of T540p? screen panels etc.

I just got a lend of a t540p with 2880x1620 panel, and it doesn't seem to be doing it for me.

Comment 12 Dan Sneddon 2014-07-16 09:15:42 UTC
(In reply to Dave Airlie from comment #11)
> also what models of T540p? screen panels etc.

My T540p has a 1920 x 1080 screen built-in. This one has the Intel integrated graphics. If the one that you have has a high-res screen, does it also have the nVidia GPU? That could be a core difference.

Were you trying it with an external monitor plugged into the mini-DisplayPort? I haven't tried it with the VGA external port, I just know that it happens with the mini-DisplayPort when plugged in either to the port on the laptop or plugged into the docking station. It happens whether or not the laptop is docked.

It has an Intel Core i7-4800MQ CPU @ 2.70GHz. 16GB of RAM.

Would you like any more details about the laptop hardware? I can get you the BIOS firmware version if you'd like.

Comment 13 Jack Waterworth 2014-07-16 13:21:03 UTC
I don't think I saw this issue when I used the VGA out on the laptop... only with the dock. I'll test later today.

Comment 14 Jack Waterworth 2014-07-29 16:27:14 UTC
Confirmed that using the VGA output on the laptop itself instead of the dock resolves the issue when using multiple monitors.

Comment 15 Jack Waterworth 2014-07-29 17:03:09 UTC
I'm wrong. I'm still having the issue without the mst kernel using the laptop vga output. I was too eager to try to narrow down the cause.

Comment 16 Brent Baude 2014-08-26 23:54:51 UTC
@jack and dan, can you post your model and bios information so we can help out David here.  Mine is as follows:

[bbaude@localhost ~]$ journalctl -b |grep DMI | grep LENOVO
Aug 26 18:24:15 localhost.localdomain kernel: DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET65WW (2.13 ) 05/15/2014

Comment 17 Dan Sneddon 2014-08-27 00:37:34 UTC
(In reply to Brent Baude from comment #16)
> @jack and dan, can you post your model and bios information so we can help
> out David here.  Mine is as follows:

Mine is:
[dsneddon@dsneddon-t540p ~]$ journalctl -b | grep DMI | grep LENOVO
Aug 12 10:33:30 dsneddon-t540p kernel: DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET31WW (1.11 ) 10/16/2013

Comment 18 Brent Baude 2014-08-27 01:02:23 UTC
Created attachment 931218 [details]
dmesg w/drm.debug=6 and kernel-3.17.0-0.rc2.git0.1.fc22.x86_64

Comment 19 Brent Baude 2014-08-27 01:06:42 UTC
@Dan, we appear to have the same model # which differs from David.  So I think we are onto something.  One difference in behaviour however is that with mine, I can operate with the lid closed (docked) and only one external monitor.  The pauses for me only occur with the laptop lid closed (or deactivated) AND two external monitors.  FWIW

Comment 20 Jack Waterworth 2014-08-27 16:41:47 UTC
Aug 13 11:04:15 galileo kernel: DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET31WW (1.11 ) 10/16/2013

Comment 21 Jack Waterworth 2014-09-03 15:22:37 UTC
My coworker picked up a T540p this morning and does NOT have the issue. Here is the output from the command for bios version:

DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET62WW (2.10 ) 03/19/2014

Comment 22 Brent Baude 2014-10-14 13:20:08 UTC
Hi Dave, were you able to get the same model from your outfit to test with?

Comment 23 Brent Baude 2014-10-31 19:02:25 UTC
Hi Dave, it doesnt seem like new kernels fix this.  Can you confirm on where you are at with this?

Comment 24 Brent Baude 2014-11-06 14:26:13 UTC
At David, I built Fedora-3.17.2-200.fc20.x86_64 with the patch you told me about -> https://www.freedesktop.org/patch/35188/

While I did need to reformat the patch to apply clean to 3.17, it apparently fixes the issue.  So far I have tested with two external monitors and the lid closed from bootup.  I see no pauses.  

Are there other tests you'd like me to test?

If not, can we get this into Fedora proper?

Comment 25 Sumit Bose 2014-11-11 11:30:17 UTC
I've created a scratch build (http://koji.fedoraproject.org/koji/taskinfo?taskID=8094657) with this patch and the latest from the Fedora Kernel package git repo which fixes the issue for me as well.

Comment 26 Rich Megginson 2014-11-26 02:52:24 UTC
I have the same problem on F20.  It happens if I use a docking station or not.  The only common thread is that I'm using an external monitor.  I've tried both VGA and DVI connectors - same problem, no difference.  Here is my kernel:

3.17.3-200.fc20.x86_64 #1 SMP Fri Nov 14 19:45:42 UTC 2014

sudo journalctl -b|grep DMI|grep LENOVO
Nov 25 19:43:34 localhost.localdomain kernel: DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET62WW (2.10 ) 03/19/2014

Any chance we can get a fix for this in F20?

Comment 27 Ken Holden 2014-12-02 20:23:28 UTC
Same problem as well on F20. Doesn't occur in kernel 3.16.7-200.fc20.x86_64 or prior.  Noticed it with kernel-3.17.2-200, 3.17.3-200 and now 3.17.4-200.  Hardware is Lenovo T540p and docking station.  Occurs when I am connected to external monitor with laptop lid closed.  Once I open laptop the freezes stop. If I boot into 3.16.7-200 kernel, problem doesn't occur.

3.17.4-200.fc20.x86_64 #1 SMP Fri Nov 21 23:26:41 UTC 2014

journalctl -b |grep DMI | grep LENOVO
Dec 02 14:53:30 kht540p kernel: DMI: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET66WW (2.14 ) 07/01/2014

Comment 28 Dave Airlie 2014-12-02 23:34:00 UTC
just FYI patch for this is queued up for the next F20 kernel.

Comment 29 Jack Waterworth 2014-12-11 14:53:44 UTC
problem still occurs for me on 3.17.4-301.fc21.x86_64

Comment 30 Dave Airlie 2014-12-15 10:34:24 UTC
please test 3.17.6-200.

Comment 31 Ken Holden 2014-12-15 12:48:14 UTC
Running 3.17.6-200 on F20 now with in my docking station and the freeze is gone.  Thank you.

Comment 32 Rich Megginson 2014-12-15 16:23:50 UTC
(In reply to Dave Airlie from comment #30)
> please test 3.17.6-200.

Works for me!  Thanks!

Comment 33 xsytry 2014-12-16 14:36:16 UTC
(In reply to Dave Airlie from comment #30)
> please test 3.17.6-200.

It looks like the bug is fixed. Thanks.

Comment 34 jgarriso 2014-12-16 14:50:00 UTC
Works for me! Thanks!

Comment 35 Dan Sneddon 2015-01-20 00:15:07 UTC
To finally close out this ticket, I can report that the newer kernels have fixed this issue for me. Thanks!!!


Note You need to log in before you can comment on or make changes to this bug.