Bug 1118453 - run-tests does not handle running single tests
Summary: run-tests does not handle running single tests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: krishnan parthasarathi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 18:12 UTC by Anders Blomdell
Modified: 2015-11-03 23:06 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:36:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anders Blomdell 2014-07-10 18:12:17 UTC
Description of problem:

run-tests does not handle running single tests

Mostly an exercise in understanding gerrit and writing my own test-cases.

Comment 1 Anand Avati 2014-07-10 18:22:05 UTC
REVIEW: http://review.gluster.org/8291 (Adding possibility to run single tests) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 2 Anand Avati 2014-07-11 16:03:05 UTC
REVIEW: http://review.gluster.org/8291 (Adding possibility to run single tests) posted (#2) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 3 Anand Avati 2014-07-14 14:23:06 UTC
REVIEW: http://review.gluster.org/8291 (Adding possibility to run single tests) posted (#3) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 4 Anand Avati 2014-07-15 10:30:02 UTC
REVIEW: http://review.gluster.org/8291 (Add possibility to run single tests) posted (#4) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 5 Anand Avati 2014-07-15 10:32:07 UTC
REVIEW: http://review.gluster.org/8291 (Add possibility to run single tests) posted (#5) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 6 Anand Avati 2014-07-16 05:59:51 UTC
COMMIT: http://review.gluster.org/8291 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit de359f8b2aa1be9127b6d27a6283c202d089cd81
Author: Anders Blomdell <anders.blomdell@control.lth.se>
Date:   Thu Jul 10 20:17:25 2014 +0200

    Add possibility to run single tests
    
    Change-Id: I9282b711c09611bd0fd4cc814f3ec34aa67d10c0
    BUG: 1118453
    Signed-off-by: Anders Blomdell <anders.blomdell@control.lth.se>
    Reviewed-on: http://review.gluster.org/8291
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Niels de Vos 2014-09-22 12:44:44 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 8 Niels de Vos 2014-11-11 08:36:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.