Bug 1118475 - cert does remain case sensitive
Summary: cert does remain case sensitive
Keywords:
Status: CLOSED DUPLICATE of bug 1118810
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-10 20:06 UTC by Chris Roberts
Modified: 2014-07-17 13:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 13:55:26 UTC


Attachments (Terms of Use)

Description Chris Roberts 2014-07-10 20:06:16 UTC
Description of problem:

when installing satellite 6 with a upper case hostname ie Toledosat6 the installer creates a cert with a lowercase cert and errors out the installer

How reproducible:


Steps to Reproduce:
1. Install satellite 6 with katello with upper case hostname ie Toledosat6
2. installer creates cert with lowercase and errors out becase it cant find the hostname with the uppercase
3.

Actual results:
/Stage[main]/Puppet::Server::Config/Exec[puppet_server_config-generate_ca_cert]: Failed to call refresh: /usr/bin/puppet cert --generate Toledosat6.usersys.redhat.com returned 24 instead of one of [0]
 /Stage[main]/Puppet::Server::Config/Exec[puppet_server_config-generate_ca_cert]: /usr/bin/puppet cert --generate Toledosat6.usersys.redhat.com returned 24 instead of one of [0]
 Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait httpd start' returned 1: Starting httpd: [FAILED]
 /Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait httpd start' returned 1: Starting httpd: [FAILED]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
Installing             Done                                               [100%] [................................................................

Expected results:
install to finish normal

Additional info:
Shughes is working on a patch for this

Comment 1 RHEL Product and Program Management 2014-07-10 20:14:20 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Bryan Kearney 2014-07-17 13:55:26 UTC

*** This bug has been marked as a duplicate of bug 1118810 ***


Note You need to log in before you can comment on or make changes to this bug.