Bug 1118502 - Rubygem-Staypuft: Neutron deployment gets stuck on 60% installing the Neutron Networker.
Summary: Rubygem-Staypuft: Neutron deployment gets stuck on 60% installing the Neutro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 21:21 UTC by Alexander Chuzhoy
Modified: 2016-04-26 13:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:46 UTC


Attachments (Terms of Use)
production.log from the staypuft host. (831.67 KB, text/x-log)
2014-07-10 21:21 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Alexander Chuzhoy 2014-07-10 21:21:54 UTC
Created attachment 917189 [details]
production.log from the staypuft host.

Rubygem-Staypuft:  Neutron deployment gets stuck on 60% installing the Neutron  Networker.

Environment:
ruby193-rubygem-staypuft-0.1.11-1.el6ost.noarch
openstack-foreman-installer-2.0.13-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-7.el6ost.noarch
openstack-puppet-modules-2014.1-18.1.el6ost.noarch
rhel-osp-installer-0.1.0-2.el6ost.noarch


Steps to reproduce:
1. Install and run the rhel-osp-installer.
2. Create a Neutron deployment with 3 nodes ( Controller (Neutron) + Neutron Networker + Compute (Neutron) )
3. Tenant Network Type: flat and set eth0 for network and compute nodes in the respective fields on the same page.

Result:
the deployment gets paused on 53.3%.
In "more details" I see that the Neutron Networker is stuck on 60%.
Trying to run the puppet agent manually on that node gives me:
"
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: join(): Requires array to work with at /etc/puppet/environments/production/modules/neutron/manifests/agents/ovs.pp:57 on node 525400868094.lab.eng.rdu2.redhat.com
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
"


Expected result: The deplloyment should complete 100% with no errors.

Comment 1 Hugh Brock 2014-07-10 21:28:23 UTC
From the logs,

no puppet_class: quickstack::pacemaker::mysql found
missing param backend_gluster in quickstack::pacemaker::cinder trying to set default_value: false found in puppetclasses: []

Not sure if that is relevant but it is worth reviewing. Note this is non-HA Neutron.

Comment 4 Alexander Chuzhoy 2014-07-10 21:49:27 UTC
The respective line in puppet manifest is:
br_map_str = join($bridge_mappings, ',')

Checking the UI - I see that the value being configured for the "bridge mappings" parameter is  ["inter-vlan:br-eth0","ext-vlan:br-ex"]

Comment 5 Jiri Stransky 2014-07-11 09:14:09 UTC
I looked at the Astapor side just to be sure - we're just passing the parameter through and the defaults seem to be set to empty array everywhere.

Just guessing - could the problem be that the staypuft seeds seem to default the parameter to a string? (Maybe the parameter type is detected from it and it's getting passed to Puppet as string even when not using the default value?)

https://github.com/theforeman/staypuft/blob/master/app/lib/staypuft/seeder.rb#L191

Comment 6 Petr Chalupa 2014-07-11 11:40:29 UTC
The value seeded in seeder is later evaluated to array so that is fine. About the value itself and why we are setting it that is better to ask sseago. I do not know.

Comment 7 Scott Seago 2014-07-11 17:32:57 UTC
Fix merged on master from https://github.com/theforeman/staypuft/pull/213

Soon to be in 0.1.13 gem build.

Comment 10 Alexander Chuzhoy 2014-07-24 23:03:09 UTC
Verified: failedQA.
Reproduced on rhel-osp-installer-0.1.4-1.el6ost.noarch

Comment 11 Mike Burns 2014-07-28 12:53:15 UTC
Move back to ON_QA.  The problem in this bug is that a parameter is missing.  The missing param was verified as no longer missing by many people since then.  Any new issues should be filed separately.

Comment 13 errata-xmlrpc 2014-08-04 18:35:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.