Bug 1118515 - numad and libvirt problem
Summary: numad and libvirt problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 1154071
TreeView+ depends on / blocked
 
Reported: 2014-07-10 22:51 UTC by Dax Kelson
Modified: 2015-03-05 10:42 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.13.1-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:42:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0458 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2015-03-05 15:17:00 UTC

Description Dax Kelson 2014-07-10 22:51:29 UTC
Description of problem:
When configuring KVM virtual machines to use NUMA pre-placement advice via "<vcpu placement="auto">1</vcpu>", libvirt talks to the numad daemon and the following denials are generated:


type=AVC msg=audit(1405024011.291:6564): avc:  denied  { open } for  pid=23257 comm="numad" path="/var/log/numad.log" dev="dm-0" ino=68988305 scontext=system_u:system_r:numad_t:s0 tcontext=system_u:object_r:virt_log_t:s0 tclass=file
type=AVC msg=audit(1405024011.292:6565): avc:  denied  { unix_read unix_write } for  pid=23257 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=msgq
type=AVC msg=audit(1405024581.409:6576): avc:  denied  { associate } for  pid=23577 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=msgq
type=AVC msg=audit(1405024674.129:6583): avc:  denied  { read } for  pid=23633 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=msgq
type=AVC msg=audit(1405024818.834:6595): avc:  denied  { receive } for  pid=23679 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:object_r:virtd_t:s0 tclass=msg
type=AVC msg=audit(1405025003.412:6673): avc:  denied  { write } for  pid=23740 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=msgq
type=AVC msg=audit(1405025134.416:6737): avc:  denied  { send } for  pid=24108 comm="numad" key=-559038737  scontext=system_u:system_r:numad_t:s0 tcontext=system_u:object_r:virtd_t:s0 tclass=msg

Using audit2allow makes everything work.


Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-153.el7_0.10.noarch

How reproducible:
every time


Additional info:

Comment 3 Miroslav Grepl 2014-10-06 10:46:54 UTC
Has been fixed.

commit 064f87bc12a49581277e970d64458a6d6841e1da
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Fri Jul 11 11:15:42 2014 +0200

    Add support for KVM virtual machines to use NUMA pre-placement.

Comment 6 Milos Malik 2015-01-05 14:09:18 UTC
The automated TC passed. The bug seems to be fixed on selinux-policy side.

Comment 8 errata-xmlrpc 2015-03-05 10:42:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0458.html


Note You need to log in before you can comment on or make changes to this bug.