Bug 111852 - sendmail-8.12.10-1 does not create the pam.d smtp module
Summary: sendmail-8.12.10-1 does not create the pam.d smtp module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-10 22:38 UTC by Cameron Christensen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-11 13:31:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cameron Christensen 2003-12-10 22:38:13 UTC
Description of problem:
The /etc/pam.d/smtp module is missing after installing the
sendmail-8.12.10-1.i386.rpm.  Running an rpmverify also reports file
file as missing

Version-Release number of selected component (if applicable):
sendmail-8.12.10-1

How reproducible:
100%

Steps to Reproduce:
1. Install the sendmail-8.12.10-1.i386.rpm
2.
3.
  
Actual results:

Expected results:
the 

Additional info:
The smtp or sendmail.pam file does exist in the
sendmail-8.12.10-1.src.rpm but does not get created during
rpm install.

Comment 1 Cameron Christensen 2003-12-10 22:43:27 UTC
When smtp auth authentication is enabled for sendmail, the actual
authenticaion process fails and reports this to /var/log/messages

Dec  9 17:06:49 station2 saslauthd[19511]: do_auth         : auth
failure: [user=username] [service=smtp] [realm=] [mech=pam]
[reason=PAM auth error]
Dec  9 17:06:49 station2 sendmail[19650]: Password verification failed

Work-around was to create the /etc/pam.d/smtp file by hand and add

#%PAM-1.0
auth       required     pam_stack.so service=system-auth
account    required     pam_stack.so service=system-auth



Comment 2 Florian La Roche 2003-12-11 13:31:29 UTC
Do you have also postfix installed? I have a bug-report that the file
can get deleted by postfix since it is not setup via "alternatives".

Current rpm has this bug fixed, thanks for reporting this.

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.