Bug 1118549 - [RFE][neutron]: FWaaS changes to support Distributed Virtual Router(DVR)
Summary: [RFE][neutron]: FWaaS changes to support Distributed Virtual Router(DVR)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 6.0 (Juno)
Assignee: lpeer
QA Contact: Ofer Blaut
URL: https://blueprints.launchpad.net/neut...
Whiteboard: upstream_milestone_juno-rc1 upstream_...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 04:04 UTC by RHOS Integration
Modified: 2016-04-26 13:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-19 11:50:46 UTC


Attachments (Terms of Use)

Description RHOS Integration 2014-07-11 04:04:21 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/neutron/+spec/neutron-dvr-fwaas.

Description:

The DVR model breaks basic FWaaS implementation as FWaaS relies on seeing both directions of traffic (stageful)  at the router programmed with Firewall rules. DVR by design distributes routing across compute nodes to achieve scalability and this has unfavorable consequences for FWaaS. The first step is to at least ensure that we have an L3 Perimeter Firewall working for the North-South traffic use case.

Specification URL (additional information):

None

Comment 5 Nir Yechiel 2015-03-19 11:50:46 UTC
This RFE was automatically opened to track status of upstream development. At this point we see no reason to keep track of this in Red Hat bugzilla, thus closing it.


Note You need to log in before you can comment on or make changes to this bug.