Bug 1118594 - TBf6c835f4 NCHardwareList.py:482:save:AttributeError: Hardware instance has no attribute 'type'
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: Hardware instance has n...
Keywords:
Status: CLOSED DUPLICATE of bug 955310
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network
Version: 5.10
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 07:03 UTC by Vivek Kumar
Modified: 2014-08-18 08:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 08:50:01 UTC


Attachments (Terms of Use)
contains the Bug thrown (2.77 KB, text/plain)
2014-07-11 07:03 UTC, Vivek Kumar
no flags Details

Description Vivek Kumar 2014-07-11 07:03:47 UTC
Created attachment 917256 [details]
contains the Bug thrown

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Harald Hoyer 2014-08-18 08:49:37 UTC
Component: system-config-network
Version: 1.3.99.21
Summary: TBf6c835f4 NCHardwareList.py:482:save:AttributeError: Hardware instance has no attribute 'type'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 781, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 370, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 398, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 482, in save
    if (hw.Type == ETHERNET or \
AttributeError: Hardware instance has no attribute 'type'

Local variables in innermost frame:
self: HardwareList.Ethernet.eth0.Status=system
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=igb
HardwareList.Ethernet.eth0.Description=Intel Corporation I350 Gigabit Network Connection
HardwareList.Ethernet.dev11519.Status=system
HardwareList.Ethernet.dev11519.Name=dev11519
HardwareList.Ethernet.dev11519.Type=Ethernet
HardwareList.Ethernet.dev11519.Card.ModuleName=igb
HardwareList.Ethernet.dev11519.Description=Intel Corporation I350 Gigabit Network Connection
HardwareList.Ethernet.eth2.Status=system
HardwareList.Ethernet.eth2.Name=eth2
HardwareList.Ethernet.eth2.Type=Ethernet
HardwareList.Ethernet.eth2.Card.ModuleName=igb
HardwareList.Ethernet.eth2.Description=Intel Corporation I350 Gigabit Network Connection
HardwareList.Ethernet.eth3.Status=system
HardwareList.Ethernet.eth3.Name=eth3
HardwareList.Ethernet.eth3.Type=Ethernet
HardwareList.Ethernet.eth3.Card.ModuleName=igb
HardwareList.Ethernet.eth3.Description=Intel Corporation I350 Gigabit Network Connection
HardwareList.Ethernet.usb0.Status=system
HardwareList.Ethernet.usb0.Name=usb0
HardwareList.Ethernet.usb0.Type=Ethernet
HardwareList.Ethernet.usb0.Card.ModuleName=cdc_ether
HardwareList.Ethernet.usb0.Description=IBM Corp. RNDIS/Ethernet Gadget
HardwareList.BOND.bond0.Status=configured
HardwareList.BOND.bond0.Name=bond0
HardwareList.BOND.bond0.Type=BOND
HardwareList.BOND.bond0.Card.ModuleName=bonding
HardwareList.BOND.bond0.Description=bonding
HardwareList.Ethernet.eth1.Status=configured
HardwareList.Ethernet.eth1.Name=eth1
HardwareList.Ethernet.eth1.Type=Ethernet
HardwareList.Ethernet.eth1.Card.ModuleName=igb
HardwareList.Ethernet.eth1.Description=igb

modules: <netconfpkg.NCHardwareList.MyConfModules instance at 0x19b2fcf8>
hw: Hardware.Status=configured
Hardware.Name=bond0
Hardware.Type=BOND
Hardware.Card.ModuleName=bonding
Hardware.Description=bonding

wvdial: <rhpl.ConfSMB.ConfSMB instance at 0x19b30320>
type: Ethernet
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x19b42128>
mod: eth1

Comment 2 Harald Hoyer 2014-08-18 08:50:01 UTC

*** This bug has been marked as a duplicate of bug 955310 ***


Note You need to log in before you can comment on or make changes to this bug.