Bug 1118596 - atlas-3.10.2 is available
Summary: atlas-3.10.2 is available
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: atlas
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Frantisek Kluknavsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks: ARMTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-07-11 07:06 UTC by Upstream Release Monitoring
Modified: 2016-02-03 08:01 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-20 15:36:43 UTC


Attachments (Terms of Use)
atlas_spec_new_3.10.2.patch (1.51 KB, patch)
2014-07-31 07:16 UTC, Michel Normand
no flags Details | Diff

Description Upstream Release Monitoring 2014-07-11 07:06:50 UTC
Latest upstream release: 3.10.2
Current version/release in Fedora Rawhide: 3.10.1-13.fc21
URL: http://sourceforge.net/api/file/index/project-name/math-atlas/mtime/desc/limit/200/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Fedora Admin XMLRPC Client 2014-07-26 17:14:56 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Admin XMLRPC Client 2014-07-28 07:46:13 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2014-07-28 07:47:23 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Michel Normand 2014-07-31 07:16:01 UTC
Created attachment 922832 [details]
atlas_spec_new_3.10.2.patch

Comment 5 Michel Normand 2014-07-31 07:17:59 UTC
(In reply to Michel Normand from comment #4)
> Created attachment 922832 [details]
> atlas_spec_new_3.10.2.patch

with this patch on spec file the 3.10.2 new version allow to build new ppc64le archi as per scratch build http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1965167

Comment 6 Michel Normand 2014-07-31 07:32:14 UTC
build on koji primary is failing because of arm
http://koji.fedoraproject.org/koji/taskinfo?taskID=7218575

Comment 7 Michel Normand 2014-07-31 07:39:42 UTC
*** Bug 1080073 has been marked as a duplicate of this bug. ***

Comment 8 Orion Poplawski 2015-04-03 03:08:28 UTC
I'm wondering if we should move to a developer release?

   NOTE: 3.10.2 is terribly out of date, and was released only because the
      threading rewrite it taking too long.  If possible, you should use a
      developer release after testing that it works for your particular
      platform.  In particular, developer releases are *much* faster for any
      x86 that uses AVX or later SIMD ISA, or any machine with ncores >= 8.
      The developer release also supports ARM architectures better (though
      performance is not hugely better if you can get stable installed).

but I don't know what the other implications of this are.

Comment 9 Orion Poplawski 2015-04-03 16:19:52 UTC
Well, they both fail on arm currently the same was, so that's not going to help directly:

make -f Make.top startup
make[1]: Entering directory '/builddir/build/BUILD/ATLAS/arm_base'
Make.top:1: Make.inc: No such file or directory
make[1]: *** No rule to make target 'Make.inc'.  Stop.
make[1]: Leaving directory '/builddir/build/BUILD/ATLAS/arm_base'
Makefile:537: recipe for target 'startup' failed
make: *** [startup] Error 2

Comment 10 Orion Poplawski 2015-05-14 04:44:16 UTC
Mind you, I'm not at all familiar with ATLAS's crazy build system.  But I seem to be getting farther with setting "-Si archdef 0" on arm, and I'm wondering if that's what we should be doing.   Scratch build with this:

http://koji.fedoraproject.org/koji/taskinfo?taskID=9731469

There is also this note in the spec:

#beware - arch constant can change between releases
%define arch_option -A 46

So perhaps it changed - but I don't know how to check.  Perhaps this:

# ./xarchinfo_linux 
MACHTYPE=51
PTR BITS=32, SURE=0

Just running configure shows:

Architecture configured as  ARMv7 (51)

so perhaps we just need to not pass -A anymore for arm? Scratch build without -A/-Si:

http://koji.fedoraproject.org/koji/taskinfo?taskID=9731878

Comment 11 Orion Poplawski 2015-05-14 17:28:28 UTC
Well, the "-Si archdef 0" build took 13 hours compared to 2:20 for auto detect, so at least from that standpoint it seems to be the way to go.  And the autodetect appears to work.  I'm going to push that to rawhide.

Comment 12 Upstream Release Monitoring 2015-05-14 19:47:51 UTC
orion's atlas-3.10.2-1.fc23 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=636958

Comment 13 Upstream Release Monitoring 2015-05-20 14:21:05 UTC
fkluknav's atlas-3.10.2-2.fc23 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=638100


Note You need to log in before you can comment on or make changes to this bug.