Bug 1118628 - man docker run has multiple missing dashes
Summary: man docker run has multiple missing dashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Henry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1109938
TreeView+ depends on / blocked
 
Reported: 2014-07-11 07:57 UTC by Lukas Doktor
Modified: 2019-03-06 00:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Lukas Doktor 2014-07-11 07:57:33 UTC
Description of problem:
In opts explanations multiple long options are listed with only single `-` instead of `--`.

Version-Release number of selected component (if applicable):
docker-0.11.1-10.el7.x86_64
docker-io-1.0.0-3.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man docker run

Actual results:
...
-d, -detach..
-e, -env...
-m, -memory...
...

Expected results:
...
-d, --detach...
-e, --env...
-m, --memory...
...

Additional info:
Few of them are OK, but most of them have only a single dash.

Comment 2 William Henry 2014-07-23 21:00:30 UTC
Pull request waiting to be merged upstream:

https://github.com/dotcloud/docker/pull/7199

Comment 3 William Henry 2014-07-24 14:04:16 UTC
Merged upstream.
https://github.com/dotcloud/docker/pull/7199

Comment 4 Lukas Doktor 2014-08-11 07:57:57 UTC
Fixed in docker-1.1.2-9.el7.x86_64

Comment 5 errata-xmlrpc 2014-09-18 20:46:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.