Bug 1118666 - Missing double start character for "--help" in man document
Summary: Missing double start character for "--help" in man document
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: John Keck
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1109938
TreeView+ depends on / blocked
 
Reported: 2014-07-11 08:48 UTC by Luwen Su
Modified: 2019-03-06 01:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Luwen Su 2014-07-11 08:48:41 UTC
Description of problem:
Missing ** in most of "help" document

Version-Release number of selected component (if applicable):
docker-1.0.0-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Through
https://github.com/lsm5/docker/commit/f2578a47be666e71c19553aa2d0d7fc89547662b,
all  [**--help] should be  [**--help**], otherwise it will looks like
#man docker commit
 -a, --author="" Author name.  (eg.  "John Hannibal Smith <hannibal@a-team.com>"

       **--help Print Usage statement

       -m, --message="" Commit message

which is what the docker shows now.

2.And different command will treat **--help as different ways
#docker cp **--help

Usage: docker cp CONTAINER:PATH HOSTPATH

Copy files/folders from the PATH to the HOSTPATH

  --help=false       Print usage
docker commit **--help
2014/07/11 16:01:48 Error: No such container: **--help

Comment 2 Daniel Walsh 2014-07-15 16:50:36 UTC
Fixed in docker-1.1.0-1.el7.x86_64

Comment 3 Luwen Su 2014-08-01 08:16:16 UTC
The [**--help] still exist in latest docker rpm....


# docker version
Client version: 1.1.2
Client API version: 1.14
Go version (client): go1.2.2
Git commit (client): 2a31a87/1.1.2
OS/Arch (client): linux/amd64
Server version: 1.1.2
Server API version: 1.14
Go version (server): go1.2.2
Git commit (server): 2a31a87/1.1.2

# rpm -q docker
docker-1.1.2-5.el7.x86_64

e.g.
#man docker commit

SYNOPSIS
       docker commit [**--help][-a|--author[=AUTHOR]] [-m|--message[=MESSAGE]] CONTAINER [REPOSITORY[:TAG]]

Comment 4 Daniel Walsh 2014-08-04 17:53:21 UTC
fixed in docker-1.1.2-6.el7

Comment 5 Luwen Su 2014-08-05 09:34:27 UTC
# rpm -q docker
docker-1.1.2-6.el7.x86_64

Checked both the command line and man file included in .src rpm, works well.

Set verified

Comment 6 errata-xmlrpc 2014-09-18 20:46:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.