Bug 1118669 - Problem during install, caused issues with ElasticSearch - could not publish a content view - error 404
Summary: Problem during install, caused issues with ElasticSearch - could not publish ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-11 08:50 UTC by Ade Bradshaw
Modified: 2019-08-12 14:07 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:25:33 UTC


Attachments (Terms of Use)
Katello Install Logs (240.29 KB, application/x-gzip)
2014-07-11 08:50 UTC, Ade Bradshaw
no flags Details

Description Ade Bradshaw 2014-07-11 08:50:25 UTC
Created attachment 917281 [details]
Katello Install Logs

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run katello-install
2. Re-run the katello install (due to issue the first time)
3. Try to publish a content view

Actual results:

# hammer content-view publish --id 2  --organization "blah"
Could not publish the content view:
  404 : {"error":"IndexMissingException[[katello_distribution] missing]","status":404}


Expected results:
Content view to be published


Additional info:
This was resolved by running 
  
   foreman-rake katello:reindex

Comment 1 RHEL Product and Program Management 2014-07-11 09:14:20 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Andrew Schofield 2014-07-25 18:14:58 UTC
Also just encountered this when trying to publish a content view via the web gui. foreman-rake katello:reindex resolved thie for me too.

Comment 5 jcallaha 2016-06-09 15:36:49 UTC
Verified in Satellite 6.2 Beta Snap 15.

Currently not seeing any issues with publishing/promoting multiple versions of content views. Additionally, incremental updates are working as expected.

Comment 6 Bryan Kearney 2016-07-27 11:25:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.