Bug 1118680 - R-3.1.1 is available
Summary: R-3.1.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 09:01 UTC by Upstream Release Monitoring
Modified: 2014-09-09 22:23 UTC (History)
3 users (show)

Fixed In Version: rkward-0.6.1-9.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-06 20:30:32 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2014-07-11 09:01:30 UTC
Latest upstream release: 3.1.1
Current version/release in Fedora Rawhide: 3.1.0-9.fc21
URL: http://cran.rstudio.com/banner.shtml

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 jonathan baron 2014-07-12 10:21:56 UTC
I appreciate all the work that you do to maintain the R rpms, and I have been using them on all my my machines, if only because it became difficult to configure the source to make html help files and nothing else (as in http://finzi.psych.upenn.edu). And it is nice to see that an RPM is already being made for the latest version. (The last one took a very long time, but probably because there were so many big changes.)

But the recent change in which various programs (lapack, I think) have been re-named and made part of Fedora's R distribution has created some difficulties. I don't know what the answer is, but here are two of them. One is that I now have to rely on Fedora RPM packages rather than some CRAN packages such as msm, which has been updated some time ago on CRAN but is still not updated on Fedora. Since most CRAN packages I use do not have RPMs at all, it would be nice not to have to rely on Fedora for some of these. The other is rstudio, which I had managed to get working despite the fact that it is neither on CRAN nor in Fedora. I can't install it now even from source.

Perhaps a possible solution would involve making links from old names to new programs, or making an RPM for just the old versions so that various packages could find them.

Sorry for reporting this as a comment, but it is such a general issue that I did not know where else to put it.

Jon Baron

Comment 2 Fedora Update System 2014-07-17 14:50:46 UTC
rkward-0.6.1-9.fc20,rpy-2.3.10-2.fc20,R-3.1.1-1.fc20,R-qtl-1.32.10-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rkward-0.6.1-9.fc20,rpy-2.3.10-2.fc20,R-3.1.1-1.fc20,R-qtl-1.32.10-4.fc20

Comment 3 Fedora Update System 2014-07-17 14:50:59 UTC
rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19

Comment 4 Fedora Update System 2014-07-17 14:51:10 UTC
R-3.1.1-1.el5,R-qtl-1.32.10-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/R-3.1.1-1.el5,R-qtl-1.32.10-4.el5

Comment 5 Fedora Update System 2014-07-17 14:51:21 UTC
R-3.1.1-1.el6,R-qtl-1.32.10-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/R-3.1.1-1.el6,R-qtl-1.32.10-4.el6

Comment 6 Tom "spot" Callaway 2014-07-17 14:54:22 UTC
Hey Jon, sorry for the troubles!

You should not need to rely on Fedora for any CRAN modules, they should all build cleanly from the sources in CRAN. If they do not, feel free to send me email <tcallawa@redhat.com> and I'll try to figure out what's going wrong.

rstudio is a special case, but when we stopped using the bundled LAPACK/BLAS in our R package, we managed to break it. The good news is that they've fixed it in their preview releases: http://www.rstudio.com/products/rstudio/download/preview/

I hope that helps, try out the 3.1.1 package update and let me know if you have issues building msm against it from CRAN.

Comment 7 Fedora Update System 2014-07-19 06:06:54 UTC
Package rkward-0.6.1-9.fc19, rpy-2.3.10-2.fc19, R-3.1.1-1.fc19, R-qtl-1.32.10-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rkward-0.6.1-9.fc19 rpy-2.3.10-2.fc19 R-3.1.1-1.fc19 R-qtl-1.32.10-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8532/rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-09-06 20:30:32 UTC
R-3.1.1-1.el5, R-qtl-1.32.10-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-09-06 20:31:09 UTC
R-3.1.1-1.el6, R-qtl-1.32.10-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-09-09 22:08:30 UTC
rkward-0.6.1-9.fc19, rpy-2.3.10-2.fc19, R-3.1.1-1.fc19, R-qtl-1.32.10-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-09-09 22:23:37 UTC
rkward-0.6.1-9.fc20, rpy-2.3.10-2.fc20, R-3.1.1-1.fc20, R-qtl-1.32.10-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.