Bug 1118706 - new volume wizard: allow overcommitting storage, but warn like the new vm wizard
Summary: new volume wizard: allow overcommitting storage, but warn like the new vm wizard
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 09:38 UTC by Robin Hack
Modified: 2015-04-11 19:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-11 19:08:51 UTC


Attachments (Terms of Use)

Description Robin Hack 2014-07-11 09:38:06 UTC
Description of problem:
Hi Cole!

Version-Release number of selected component (if applicable):
virt-manager-1.0.1-3.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. 1.74 GB of free disk space on target storage

2. On step 4 of 5 (or where wizard will ask) choose:
   Enable Storage for this virtual machine
   ---> Create a disk image on the computer's hard drive:
   Ok. So I have 18.3 GB free space on my storage.
   I selected 100 GB size of qcow2 file. 
   Now, dialog box about enought disk capacity raises... Clicked to Ok,
   sup sup. Machine is up and running.

    "Me so happy."

   And Now For Something Completely Different...

3. On step 4 of 5 choose: Select managed or other existing storage
   ---> Click to Browse.
      ---> Select storage with 1.7 GB of free space
        ---> Click to New volume

Create storage volume dialog box now contains:
    Format: qcow2
    Storage Volume Quota
    VM's available space: 1.74 GB

    Max capacity: 1.0 -/+ GB

I'm not able to choose more than 1 GB. But in previous wizard flow I was able to create 100 GB qcow2 file on 18.3 GB volume.

Comment 1 Cole Robinson 2014-07-18 15:03:46 UTC
Indeed, thanks for the report. Moving to the upstream tracker since it's not a major issue

Comment 2 Cole Robinson 2015-04-11 19:08:51 UTC
Fixed upstream

commit 9d99b8caaba53eb88c3081b599a68f636a2695a1
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sat Apr 11 14:56:23 2015 -0400

    createvol: Don't cap capacity to host space (bz 1118706)
    
    Only cap allocation, since we can overcommit with sparse images.


Note You need to log in before you can comment on or make changes to this bug.